Via 135 M - problems with updating map & keeps warning about non-relevant cameras

Staffe Registered Users Posts: 1
Apprentice Seeker

I have two problems.

1) The first is about the speed camera warnings. It keeps warning (with a beeping sound) about speed cameras (and/or other insignificant cameras??) almost 'ALL THE TIME', even when there are none nearby. Last year, trying to solve this problem, I purchased and updated/installed a speed camera update. However, it did not solve the problem (when using my Via 135 M, it keeps warning about all sorts of insignificant cameras all the time. It is very annoying and I have really tried to switch off all camera warnings - but it still keeps warning about perhaps existing but mostly non-existent cameras (and certainly non-relevant cameras).

Perhaps useful background information good to know, is that,.. I inserted a microSD card at some point, and installed all of Europe map (rather than just a smaller part of the entire Europe map) and then I also purchased the updated speed camera information. (Perhaps the old information is on the device itself and the updated camera information is on the microSD card, but the unit still uses all available information and hence still warns about all sorts of today, non-existent cameras? I don't know. But I can't make my via-135 M to warn only for current real speed cameras, and I also can't make it be quiet and not warn at all about any cameras. Hoping for the best solution, which would be, warning about the updated and significant/active speed cameras only (and not red light cameras etc and who knows what all those other cameras are).

2) Later, at some point, I have not been able to update the map on my via 135 M. When trying to update the maps (using mydrive connect), after a while, there is a message that says the servers are very busy or something similar, and please try again. I have, however, tried several times by now, and for a long period of time, and it never works anymore. Hoping for help on this issue as well.

What shall I do? Shall I remove the microSD card, or not? Shall I make a factory reset? And install the updates after that (and will that give me the updated speed cameras from this year 2020, and not just the original data from when the device was manufactured back then? I saw someone mentioning something about uninstall and reinstall the mydrive connect software on the computer as well, and then update the maps etc?

A - Ideally, I would like to use the microSD card for a complete Europe map with functional updates and correct speed camera warnings according to my latest updated camera warnings from some point in time during 2020 (rather than the factory camera information from many years ago).

B - Alternatively, a fully functional locally installed map (i.e. part of Europe map) with correct / only relevant (and from 2020) speed camera warnings.

C - As a last option,
I would like either a fully installed Europe map on microSD card,
or a fully functional locally installed and updatable map (i.e. parts of Europe)
and (in both cases) no camera warning sounds at all (i.e. if my via 135 M keeps insisting on not being able to differentiate between actual, relevant speed cameras and all those other strange non-relevant camera warnings).

Hoping for help! (Recently I also activated and uploaded a log of my device)

Kind regards, Staffe


  • YamFazMan
    YamFazMan UKPosts: 21,356
    edited November 2020
    Welcome to the site....

    Re... There is a message that says the servers are very busy or something similar, and please try again. I have, however, tried several times by now, and for a long period of time, and it never works any more. Hoping for help on this issue as well.

    Firstly Try....
    Disconnect your Tomtom device....
    (Do not Reconnect your device until instructed)
    Logout of MyDrive Connect....
    From the Power menu 'Restart' your PC (NOT Turn it Off 'n' On again)....
    Run MyDrive Connect & Login... Connect & Start your device....

    If you are still having problems with MyDrive Connect... I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program will usually bring MyDrive Connect back to life...

    Stay Safe... ATB YFM