Rider 550 with MyDrive App on iPhone X — TomTom Community

Rider 550 with MyDrive App on iPhone X

lloiscclloiscc Posts: 4 [Master Traveler]
edited October 15 in RIDER
Hello, good afternoon, I have a rider 550 a month ago and I have only been able to have the traffic information for two days in a row.
The problem is that I have an Iphone X and there is no way to connect with the MyDrive application to take the traffic data and pass it to the Rider.
I'm from Barcelona and the TomTom service tells me that they are working on it, but they do not give me any solution.
I bought a GPS to have the traffic information since I use it for work, and on weekends with the motorcycle. Before I had the Rider 400 that was a little slow but it worked all right. I do not understand how they put a product on the market without first testing it, it's incredible.
I have to say that I have companions with an Android phone and they do not have any problem, in canvio with Iphone all are problems.
I'm very upset
a greeting

Comments

  • ChrisHallChrisHall Posts: 256 [Exalted Navigator]
  • lloiscclloiscc Posts: 4 [Master Traveler]
    If I know, but what solution is there ???????
    How long will we be to connect MyDriver with Rider 550 and Iphone X ??????
    I am not happy.
  • ChrisHallChrisHall Posts: 256 [Exalted Navigator]
    No solution yet. The OP sent the 550 back for a refund.

    How long have we been waiting for the hoarse voice fix? Years! The same with this I reckon.

    The product has been released too early, again. It has not been properly developed or tested.
  • DanTheMenDanTheMen Posts: 1 [New Traveler]
    Same Problem here with an iPhone 8 Plus. Unbelievable that this major problem didn’t occurred during test, if there was any test before release.
  • Andy_mcdonnellAndy_mcdonnell Posts: 3 [Apprentice Traveler]
    Same problem with iPhone 7 Plus. Says my phones connected, bluetooth icon highlighted but x through cloud and traffic Also wi-fi connection issues of a major order. On my home router (BTHomeHub6) i get authenticity problem didplayed by Rider 550 UNLESS i turn the security to NONE in the router manager. Can only connect via my iphone hotspot to a secure network. I have tried wi-fi connection via a Netgear router and connection takes up to 2 minutes BUT can drop out any time. TomTom blame stable wi-fi connection BUT strangely dozens of other products connect and stream first time, all the time. I have a Ducati Multistrada with Ducati Bluetooth connectivity system. The Tomtom will not connect to that either. My final complaint listening to music has now become an issue, its either Music or SatNav commands else the music gets interfered - i’ve tried setting the asdl slide on/off in the Rider 550 menu too.

    So no traffic, no speed camera UNLESS i turn my hotspot on and eat my iphone battery when on my bike
    So no connectivity with my bike or music

    Only bought the Rider 550 because TomTom stopped supporting their APP offering you a free DOWNGRADE to TomTom Go. That APP worked perfectly and was the best thing for the 2 years i had.

    I’m 10 emails in with TomTom customer Sevices who just fob me off with unhelpful replies about how to do a reset or how to connect to wi-fi to lengthy problems supported with photos which clearly show not only have i done this BUT are not interested to help. Extremely angre - anyone want to buy my Rider 550? - I give up.
  • Paul1dogPaul1dog Posts: 5 [Apprentice Traveler]
    I have a 550, a Honour 8x phone and a Shuberth Sc1 comms and have had nothing but problems regarding bluetooth connection, I mean 4 months of emails to TomTom. I have tried 5 different phones borrowed from family and some of them would connect but on powering down and then switching everything back on, the phones were not recognised so it meant wiping all bluetooth settings and starting over but even then the bluetooth was unreliable. In the end they sent it off to Romiania to be fixed but when I got it back and read the report it said Defect found: "Software issue-application freeze & restart" and apparently reprogrammed to factory specifics and installed the latest fully functonal software release... freeze & restart was never an issue so I've no idea was that's all about! Has anyone found a phone that works with the 550?

    I have been on the phone to TomTom AGAIN and now they are telling me they are aware of the problems with the 550 and are working on finding a solution but have no idea when this will be. Here is an email I've just received from them:

    Thank you for calling TomTom Customer Support Team. My name is Noble and I am glad to have assisted you.

    I do apologize as I cannot offer you an immediate solution for the challenge you are experiencing.

    As discussed on the call, we are aware of this ongoing issue as we are getting calls from our customer with same issue. I will appreciate your patience till a solution is in place by our technical team .

    There’s no timeline as and when this will be fixed hence we will make sure to update you as soon as this is resolved.

    We thank you for your patience and cooperation all this while.

    Have a wonderful day ahead!
  • RoadRiderRoadRider Posts: 598 [Revered Pioneer]
    My Motorola X4 works with my Rider 550. The only issue is that sometimes the Rider can't find the phone. After rebooting the phone this is solved (This happens to me max 2 times a year)

    Many Phones (iPhone & Android) do not clear the hidden cache after an update.
    A lot of issues are solved after clearing this hidden cache .
    Also the Chipset and Driver quality can be an issue. Recent Qualcom chipsets have good drivers.

    Also my Interphone tour headset works fine with my Rider 550. (Only the intercom function between (multiple) Interphone tour headset is very bad.)

    When you have Issues pairing many times this can be solved using the super save mode;

    Update your Phone (Accept iPhone leave this on iOS12)
    Factory reset your phone (and do not restore)

    Update Headset Firmware (and check is it is supported on the Rider 550)
    Factory reset Headset

    Remove all pairings on Rider (or Factory reset)

    Pair headset an phone as mentioned in the manuals.
    When you make a mistake -> back to factory reset.

    Why BT pairing can be blocked by old BT pairing setting in the device.
  • BenellistaBenellista Posts: 6 [Master Traveler]
    I have an iPhone XS too and the 550 is unusable.

    I'm sure they know the problem, i mean.. certainly someone who works for TomTom owns an iphone, but the question is ... are they able to fix this? if not, we can ask for a refund because they sold a device that cannot even pair with bluetooth?
  • RoadRiderRoadRider Posts: 598 [Revered Pioneer]
    On iPhone the best fix is switch at a WiFi Hotspot.

    Remove BT settings on Rider and iPhone.
    (Remove MyDrive App on iPhone)
    Create a WiFi hotspot on your iPhone.
    Configure WiFi on Rider 550 with hotspot settings.

    Alternative wait for Apple or TomTom to fix de iOS13 Bluetooth issue's.
  • BilbobagginsBilbobaggins Posts: 4 [Master Traveler]
    Hi guys, upgraded this evening to latest IOS and it’s connecting every time, the traffic kicks in as soon as your out of WiFi range ( but still connects etc so no input required once out of range)
  • BilbobagginsBilbobaggins Posts: 4 [Master Traveler]
    And it’s failed.... now using the WiFi workaround.....
  • TriumphRobTriumphRob Posts: 3 [Neophyte Traveler]
    Still having the connection problems to MyDrive. IPhone 7 so pretty popular phone and I can never get a stable connection. It’s appalling that TomTom still haven’t got this working. I also have regular problems with the connection to my Sena 20S dropping and when it does work, the voice is often badly distorted. And today my device and that of a mate I was riding with, spent the day rebooting themselves after doing a minor map upgrade. Almost time to bite the bullet and move to Garmin.
  • T0mahawkT0mahawk Posts: 13 [Master Explorer]
    I have the same problem. iPhone X and Rider 550. Why is there no fix for this?
  • Poweller996_Poweller996_ Posts: 4 [Apprentice Traveler]
    I have recently purchased a Tomtom Rider550 and like everyone else I am having problems with Bluetooth connection between my iPhone and the satnav.
    It’s hit and miss if the phone connects to the rider550 and more often than not it does not connect so no traffic nor call information.
    The ride app is a joke keeps saying Bluetooth not in range but it’s right next to the rider550.
    I have tried everything Tomtom have instructed me to do reset everything etc but non of this makes any difference.!!!
    It is disgusting that in this modern time a big company like Tomtom can’t get it right and sort this problem out.
    COME ON TOMTOM SORT IT OUT YOU ARE RIPPING YOUR CUSTOMERS OFF.!!!
  • kieronkieron Posts: 423
    Superusers
    edited September 26
    Hi there Poweller996_

    Here is an excerpt posted by JURES (another forum contributor) as a temporary fix for iPhones using iOS 13+ operating systems end of January -

    If you pair the gps with your iPhone WITHOUT MyDrive app, traffic works flawlessly - perfectly!
    You can even install the MyDrive app afterwards and use it for routing - but -
    JUST DONT PAIR your gps with the MyDrive app!!!
    Traffic will still work, MyDrive routing will work, the only thing that does not work will be smartphone features (calls/sms) but thats not important if using a motorbike.

    Traffic and MyDrive under iOS 13+ works!!!!!
    1. - Delete the MyDrive app on your iPhone
    2. - Delete old Bluetooth pairings of the gps on your iPhone
    3. - Connect the gps to your iPhone over Bluetooth under standard way
    4. - Install the MyDrive app
    5. - DO NOT pair your gps over the MyDrive app
    6. - Have personal hotspot on iPhone turned ON just for *Bluetooth and USB Only*
    - DO NOT pair gps with WiFi of this personal hotspot and make sure WiFi is turned off on your iPhone.

    TRAFFIC AND MYDRIVE WILL WORK NON STOP!!

    Problem is in the MyDrive app (pairing through the app) as Apple had introduced new Bluetooth security permissions.

    ~Kieron adds~

    Additionally, also using the *Bluetooth and USB Only* pairing hotspot in your iPhone settings will be required for a stable connection and has less of a drain on your phone’s battery compared to the WiFi hotspot setting.
    I am currently using my Rider 500, (Sena 5s and iPhone 7 Plus paired directly to receive calls) this way successfully.

    As JURES (the original contributor of this temporary fix) had explained, you can re-install the MyDrive app onto your phone, sign in to it and use it for routing to send to your devices, but just don’t pair the Bluetooth within the app to your gps.
  • Poweller996_Poweller996_ Posts: 4 [Apprentice Traveler]
    Many Thanks for all that I will give it a go . 👍🏻 🤞🏻
  • go_suprgo_supr Posts: 4 [Master Traveler]
    edited October 14
    Thanks for sharing! Bypassing MyDrive app during pairing configuration is a remedy! Helped me with the stable connection and Traffic Data sync between Go Supreme and iPhone 11, iOS 14.0.1 Hope it won't get timed out and disconnected after my device is in a Sleep mode.
  • cabosicicabosici Posts: 1 [Apprentice Seeker]
    edited November 9
    Hello good afternoon. I have Rider 550 and iphone 7 updated to the latest version, Interphone intercom. Since September 26 that does not work. They do not connect. And then the customer service only makes me say that you are sorry for the inconvenience caused and that you are looking for a solution. I follow all the instructions they give me to match again and there is no way. As of now, I have made the decision to report the case to the consumer office. because this is a joke.

    Mod edit: Machine translated from Spanish!
Sign In or Register to comment.

Who's Online in this Category0