Issues logging in to MyDrive Connect - macOS Mojave - keychain

MrAllison Registered Users Posts: 1
New Traveler
edited October 2020 in MyDrive Connect
Hi. After updating MyDrive Connect last week I am having issues logging in to it. Running on macOS Mojave V.
When starting MyDrive I get multiple occurrences of a password entry box saying that MyDrive can't connect to keychain for the password. Just dismissing the entry boxes eventually allows access to the app.
I know us mac users usually get the rough end of the stick when it comes to non-tested software releases but this isn't the first time this has occurred.
Anyone else having the same issue or have a solution (already tried the standard "turn it off and back on" procedure)?
Looking for a solution.



  • TofuGirl
    TofuGirl Registered Users Posts: 3
    Apprentice Seeker
    Same problem. TomTom please please help!
  • pooka
    pooka Registered Users Posts: 1
    New Seeker
    Same, can't connect, update or change maps. I will be lost tomorrow. :'(
  • rosbrock
    rosbrock Registered Users Posts: 1
    Apprentice Seeker
    Same here rather irritating takes ages to log in. use TomTom for my work roll.
  • Ste7ios
    Ste7ios Posts: 760
    Delete the related certificates from the keychain, and reinstall.
  • samdutton
    samdutton Registered Users Posts: 2
    New Traveler
    Delete the related certificates from the keychain, and reinstall.
    For those (like me) who hadn't done this before:

    1. Quit the TomTom app.

    2. Open the KeyChain Access app. (You can find this by pressing command-space.)

    3. Enter 'tomtom' to find the TomTom items.

    4. Delete them all.

    5. Reopen the TomTom app.
  • ScottWS
    ScottWS Registered Users Posts: 2
    Apprentice Traveler
    Thank you Sam, it worked - very clear and helpful.
  • saw1982
    saw1982 Registered Users Posts: 1
    New Seeker
    Hi Sam, thanks a lot.
  • texxet
    texxet Registered Users Posts: 0
    New Seeker
    Lately when I want to make an update for my TomTom GO5000 navigation, when I open the application on my computer I get a message where I am asked: enter the "login" keychain password.
    Please tell me what a keychain password is and where to find it ???
  • samdutton
    samdutton Registered Users Posts: 2
    New Traveler
    edited December 2021
    I had the same thing on macOS Monterey, and get stuck in the same loop. I can see my device name, and that six updates need to be installed, but just get the spinning wheel when I click on View Updates.

    I then followed my own instructions earlier in this thread — and make sure to Force Quit from TomTom if necessary in the first step. Works now!