TomTom Rider 40, won't switch on

WieAr1 Registered Users Posts: 2
New Seeker
Hi, I have a Rider 40. Last friday i wanted to check how much power it had because i was going away for the weekend.
When i switched it on i saw is was almost empty, so i charged it at my computer.
Just before i was about to leave i disconnected it and tried to turn it on, but i couldnt get in to work.
Now it won't turn on anymore. I have tried the reset action.
(Holding the button 30 second untill drum sound.) The sound never came.

So what to do next, any suggestions?


  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    Charge it 3 hours with a 2A or more USB charger.

    And test again.
  • WieAr1
    WieAr1 Registered Users Posts: 2
    New Seeker
    I have allready tried that, still no luck sadly
  • DougLap
    DougLap Posts: 10,057
    edited September 2020
    Hi @WieAr1

    Looks like the battery is done for.

    You can type" tomtom rider 40 battery change" in YouTube and find videos on how to. If you feel confident enough, do it yourself at your risk and find batteries and the small tool kits on Amazon or Ebay etc. Otherwise you need to contact Tomtom or find someone who offers a repair service.

  • LAURE123
    LAURE123 Posts: 1,632
    edited September 2020
    Hi all


    in addition the @DougLap message. when the battery shows obvious signs of weakness after several years of use, change it becomes the only option. This is what I did with my GO5100 at my own risk. Find the right battery model for a Rider is less easy than for a car model.

    But before retry again the suggestion of @RoadRider .Charge your device with a 2A main charger (smartphone, iphone, tablet), USB ports only give 500mah that's not enough. And with your Rider40 still connected to this power source redo a Soft Reset again to "wake up" your device. “Restart” the device requires minimal power, if the battery cannot supply it, the charger will. It's to be tried several times if necessary before to spend money.

    With your device connected to the main charger:
    Soft Reset ==> press and hold the On/Off button until you hear the drum sounds. This can take 30 seconds or more. The device restarts. If you see a black screen with white text, hold down the button until you hear the drum sounds.

    After that, let your device charge for at least 2 hours.

    I hope this will work for you.