Map update keeps looping

alvia135
alvia135 Registered Users Posts: 2
New Traveler
Trying to update the Europe map on my Tom Tom Rider. It just loops continuously. I have been in contact with Tom Tom Support (2 different people) and also someone via the Tom Tom facebook page. Over the last 3 days I have tried everything they have suggested to fix the problem. After more than 40 attempts when I attach the device it automatically starts the update again (1hr 20 mins). I have soft reset the device, recovered the device, uninstalled and re-installed Mydrive Connect, deleted the Home3 folder. un-ticked the automatic settings in Mydrive Connect. Is there someone at Tom Tom who can help me fix this problem?? I am approaching the point where I give up on Tom Tom or will they give up on helping me??

Comments

  • DougLap
    DougLap Posts: 10,116
    Superuser
    Hi @alvia135

    Have you got a map on the units internal memory and a Map on an Extra memory card? If so take the extra memory card out and see if the unit runs normally. If it does then Fully not Quick Format the Extra memory card on your PC to Fat 32 and then reinstall and Format in the TT unit then reinstall the map that was on it.

    Doug
  • Xosema
    Xosema Registered Users Posts: 43
    Legendary Explorer
    I had something similar with my GO60 a couple of years ago, as I posted here https://discussions.tomtom.com/en/discussion/1041256/updating-maps-v10-20-europe-on-an-infinite-loop#latest

    I can't remember what exactly solved the problem, as it's not clear from what I wrote, but maybe trying with a different USB cable could have been related, as the original one was not in that good shape.