Go 520: what’s the meaning “unable to connected” ? — TomTom Community

Go 520: what’s the meaning “unable to connected” ?

Winston818Winston818 Posts: 41 [Legendary Explorer]
When I connected my iPhone to the Go 520 (WiFi device) via Bluetooth, it shows the Hand-free calls is connected.
But it also shows :-1:
1) Data for traffic & other services - Unable to connect
2) smartphone messages- unable to connect

What’s does these “unable to connect “ mean?wvfpc0xamp80.jpeg
pdx5bttu5qe0.jpeg

Best Answer

Answers

  • DougLapDougLap Posts: 6,341
    Superuser
    Hi @Winston818

    If the GO520 is connected to Wifi then it will not connect option 2 for data which is Traffic as it will always use the Wfii connection for that when it is available. You need to be out of WIFI Range to check if it is still not connecting. Also you need data enabled on the Phone .

    Regarding Option 3 the messaging. You need to have the My Drive App open and working .

    Since iOS 13 has been released then messaging is basically not available as Apple appears to have made a security change in the software which stops the My Drive App working as it should. It appears that a simple change to the App is not an option for Tomtom. . The current best way to link is to:-

    Delete current Bluetooth pairings on the phone and the GO520 turn both Off and On again. Now re-pair the unit but this time do not open My Drive on the Phone. Instead turn on Bluetooth and also Personal Hotspot on the phone then pair in the normal way with the GO 520. You will get the usual pairing numbers but you will not be asked fo the Personal Hotspot password. Now whenever you want to connect your phone to the GO520 have both Bluetooth and Personal Hotspot set to On.

    You are unlikely to get the messaging to connect and work and if you do it will not maintain the facility.

    Doug
  • Winston818Winston818 Posts: 41 [Legendary Explorer]
    Hi Doug,
    Also you need data enabled on the Phone.
    How to do this on iphone?

    thanks.





  • BiberdriverBiberdriver Posts: 4 [Apprentice Traveler]
    My 520 has exactly the same issue since a certain update. Either of the Iphone or the TomTom. I tried everything to reconnect. It works with Wifi but not with the mobile data from the phone. According some discussions in the forums this must be an issue of thy MyDrive app which needs to be updated. Bad service from TomTom
  • DougLapDougLap Posts: 6,341
    Superuser
    Hi @Biberdriver

    When Apple issued IOS13 it included a security change that prevents the My Drive App now working with Bluetooth for the TT devices.

    Try deleting the pairing from both your iPhone and the 520 and then turn both units Off and On then do the following.

    Turn on Personal Hotspot in Settings on your phone then go to Bluetooth in settings on the phone and turn it on as well... Now turn on the GO520 and go to Bluetooth in settings and select Add a Phone. DO NOT open the My Drive App as previously instructed when pairing as you will not involve it in the pairing process at any stage.

    Now select the GO 520 when it appears in Bluetooth on your phone and pair the 2 units as you would normally do by accepting the numbers. Once paired you should get Traffic and probably be able to operate the unit Handsfree with the phone. The messaging facility will not work as that was what the My Drive App was facilitating.

    At all times when using the iPhone with your GO520 you must have the Personal Hotspot turned On as well as Bluetooth although you will never be asked for the Personal Hotspots password it is essential that the option is turned ON for the Bluetooth connection to be maintained.

    You should also note that if you go to the Wifi option in Settings on the GO520 the iPhone is not shown as connected via its Hotspot. This is perfectly correct.

    Regarding the My Drive App you can still use it to create routes etc as you can on the My Drive Website on a PC.

    Doug
  • Steveg64Steveg64 Posts: 2 [New Seeker]
    edited September 6
    Hi

    I have the same issue with a new GO620. I'm on Android. Mobile data is enabled. I'm not connected to wifi. My Personal hotspot is enabled. I tried deleting the connection and not using the the app but now I can't pair them. I live in Jersey and I did wonder if this particular service wasn't available here. But I don't wait until we're in the UK to find out it still doesn't work.

    Any ideas ?


    BBCode
  • DougLapDougLap Posts: 6,341
    Superuser
    Hi @Steveg64

    I would delete the Bluetooth pairing on the Phone and on the GO620 then turn both units Off/ON.

    The Personal Hotspot is required to be turned On when using the iPhone but I am not sure that it is needed on the Android Phones. So I would Pair the Phone and the GO620 including the use of the My Drive App as shown in the following video and see what happens.

    https://discussions.tomtom.com/en/discussion/1034286/get-data-hands-free-calls-and-smartphone-messages-using-your-android-phone-and-mydrive-app

    Doug
  • Steveg64Steveg64 Posts: 2 [New Seeker]
    edited September 6
    It had paired perfectly using the app, but was unable to connect to the Traffic Data and other services. One of the solutions the help text suggested was to enable the personal hotspot / bluetooth tethering. Which I did but made no difference. I did try deleting the pairing info but couldn't get it to re-pair. I have bigger problems now. Whilst checking I noticed there were updates, even though I checked at the start and there weren't any. I thought I'd try updating to see if that helped. The update crashed and now it seems to have wiped the device and it won't update !! It says it can't connect to my wifi !! And I can't get passed it. Complete tosh !!! I'm not impressed. I'm reasonably tech savvy. But my first impression of these new devices are overly complicated and flaky to say the least. It might be going back

    How do I reset it ?
  • BiberdriverBiberdriver Posts: 4 [Apprentice Traveler]
    It worked once with the hotspot mode. But then again no connection possible.
    I am not in the mood to repeat the re-connection again and again.
    This issue must be fixed definitely by TomTom!
Sign In or Register to comment.

Who's Online in this Category0