MyDrive Connect hangs at 'Getting ready' stage — TomTom Community

MyDrive Connect hangs at 'Getting ready' stage

Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
edited February 2020 in MyDrive Connect
When trying to update my TomTom I find the MyDrive Connect application hangs at Getting ready. this is after I have succesfully connected the Sat Nav and viewed and selected the updates. The only cure seems to be to reboot both the TomTom and the PC and try again. This happens on two different TomTom devices and two different PC's so it is not related to just one device. Any suggestions?

Best Answers


  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]

    Thanks that has worked this time. However neither update was large so it is strange why selecting both should cause the application to hang. Is this something TomTom are aware of and is there likely to be a fix?

  • DougLapDougLap Posts: 8,825
    Hi @Alan_in_Hemel

    The problem does not always manifest itself. It is recommended that updates are done one at a time. It is also a good idea when they have all been done that you do a Soft Reset ie when finished and the unit is on hold the On/Off button down for about 20 seconds plus until you hear the drumroll sound then let button go. The device will restart and tidy up the files whilst doing that.

    Glad you are sorted. .

  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    The problem happened again. This time I end up with the message: 'Our servers are bust right now, please try again later'. Really frustrating.
  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    Hi YamFazMan

    Sorted thanks. Until the next time. I do seem to have uninstalled and reinstalled TomTom software far more than any other, I wonder why that is.
  • filbertfilbert Posts: 21 [Master Explorer]
    YamFazMan wrote: »

    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller
    If you're using a Windows PC... Delete MyDrive Connect using the free version of Revo Uninstaller
    If you're using a Mac... Surely there must be a Deep Clean Un-installer Program available for a Mac ???

    Yes, I use AppCleaner (, seems to work well. Other apps are available in the Appstore.
    Mac OS doesn't embed software as deeply as Windows, there's no registry, for example. So simply deleting the app folder is often enough.
  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    Having tried all the suggestions above the problem keeps returning. Today I have rebooted the SatNav and the PC but still the problem persists and I am unable to update the TomTom. I am starting to think I might have to reinstall the software monthly to keep it working. This is ridiculous.
  • IanCarbarnsIanCarbarns Posts: 1 [Apprentice Seeker]
    Another cause for this is trying to update when connected via a VPN service. Need to turn VPN off before starting MyDrive or connecting device.
  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    Thanks but I am not connected via VPN. I am using home broadband connected to the router via an ethernet cable.
  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    I attempted to update my TomTom today and the problem of hanging still persisted. I therefore uninstalled TomTom MyDrive Connect and re-installed it again. Update worked. This is all getting rather silly. How do I raise this as a formal issue with TomTom?
  • YamFazManYamFazMan Posts: 20,053

    Ring Tomtom support United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    I have now adopted a process of updating my TomTom at the end of each month and re-installing the software to enable me to do that. This is also the process for my daughter and her TomTom using her laptop, so I know it is not unique to me. Next time we are buying Garmins.
  • YamFazManYamFazMan Posts: 20,053
    edited May 2020
    Glad you're sorted :)
    If you're getting fed-up with UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program... To be just as effective for giving MyDrive Connect a CPR...
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

  • Alan_in_HemelAlan_in_Hemel Posts: 9 [Master Traveler]
    Thanks YamFazMan, I found the two folders in my user local drive:
    There were no updates today as I updated yesterday but I will test this when I can and let you know how it goes.
  • Josie777Josie777 Posts: 2 [New Seeker]
    You don't need to wipe out and download the whole MyDrive Connect application. All you need to do is get rid of old files. You can do that in the settings:
    1. In TomTom MyDrive Connect application, go to the Settings (top right hand corner).
    2. Select the Downloads tab.
    3. Click on the Empty download button to clear old files.
    4. Try the download again. It should work this time.
  • Derek_A_HDerek_A_H Posts: 1 [New Traveler]
    I just bought a Tomtom Via for 10 bucks off of Kijiji, and I had this problem and did the following to fix it:

    1. Uninstalled and re-installed MyDrive Connect. As soon as a I re-installed it, it started downloading correctly. I had my device plugged into the computer the whole time I uninstalled and reinstalled
    2. Then it got hung up again, I think on 'Connecting...' or something. I had to put a memory card in my device. Then it worked!

    I always tried to do one download at a time, although sometimes I had no choice (the device hadn't been updated, ever, so it had two mandatory updates that I couldn't unclick. They worked following these steps).
This discussion has been closed.

Who's Online in this Category0