Bluetooth not working on Rider 550 — TomTom Community

Bluetooth not working on Rider 550

Norrie83Norrie83 Posts: 4 [New Seeker]
I’ve just bought a Rider 550 yesterday.

I’ve updated everything on the TomTom

My phone is the iPhone 11 Max pro OS 13.6

I have paired it with my phone for Bluetooth however now it says Bluetooth not connected.

If I tap on Bluetooth on the rider 550 it shows my phone under paired devices.

On my phones Bluetooth settings it shows 2 instances of TomTom Rider 550.

One says connected the other says disconnected.

The my drive app says device not in range

It was in range and I was using it before it disconnected while using it

I’ve told my phone to forget the TomTom in both instances and paired it with the unit 5 times now however it keeps disconnecting and I can’t use the features.

Even though my drive is telling me that no unit is in range I can still send routes from it to the rider 550...... I’m confused how and I’m assuming it’s doing it over WiFi ?

My concern is if I don’t have the Bluetooth active then I won’t have real-time traffic Speed cameras etc will I ?

Not sure how I can get the live traffic etc without Bluetooth ?

I can get the Bluetooth active and working for a minute or 2 by uninstalling the app, forgetting the TomTom on my phones blue tooth setting restarting the TomTom and starting again.

It will then show connected but just disconnects and no way to keep it connected.

I’ve no issues with any other Bluetooth devices I use daily from my phone only this TomTom Rider 550

As a test I’ve just tried this all with a old phone a Xperia Z3 and I’ve all the same issues.

I hope someone can help before I return it to the shop and pick up a equivalent from another manufacturer :(

Thanks in advance for any help with this.

Best Answer

Answers

  • DougLapDougLap Posts: 8,003
    Superuser
    Hi @Norrie83

    Try the following.

    Completely forget the TT units Bluetooth connections on the phone and also delete the connection on the TT unit. Having then turned both units Off and On then do the following bearing in mind not to open the My Drive App at any time.

    Go to Personal Hotspot in the iPhone Settings and turn it on.
    Go to Bluetooth settings in the iPhone and turn that on.
    Turn the TT unit on and go to Bluetooth in Settings and select add a phone
    When the TT unit appears in Bluetooth on the phone Tap it and then Tap the pairing numbers when they appear on the phone and TT unit

    The two units are now paired and you should get Traffic etc and also will probably get the handsfree working.

    The problem is as a result of a Security Change when Apple issued IOS13 and later which has stopped the My Drive App working as it should. Although you will not be asked for your Personal Hotspot Password during the pairing it is essential that you have both Bluetooth and Personal Hotspot On when you connect to the TT otherwise the connection will not happen.

    You will not get the messaging facility as that was what the My Drive App involvement was there for but that will not work and it appears a simple or major change to the App is not an option to resolve the issue.

    From now on only use the My Drive App for Route or My place creation etc as you would if in it on the PC.

    Here are details from another post of a suggestion made by @jures which has been successful.


    Here is an excerpt posted by JURES (another forum contributor) as a temporary fix for iPhones using iOS 13+ operating systems end of January -

    If you pair gps with iPhone without MyDrive app, traffic works flawlessly - perfectly!
    You can even install the MyDrive app afterwards and use it for routing - but - JUST DONT PAIR gps over the app!!!
    Traffic will still work, MyDrive routing will work, the only thing that does not work will be smartphone features (calls / sms) but thats not important on bike.

    Traffic and MyDrive under iOS 13+ works!!!!!
    - Delete MyDrive app on iPhone
    - Delete old Bluetooth pairings of gps on iPhone
    - Connect gps to iPhone over Bluetooth under standard way
    - Install MyDrive app
    - DO NOT pair gps over the app
    - have personal hotspot on iPhone turned ON just for Bluetooth and USB Only
    - DO NOT pair gps with WiFi of this personal hotspot

    TRAFFIC AND MY DRIVE WILL WORK NON STOP!!

    Problem is in the app (pairing through the app)

    Using the Bluetooth and USB Only pairing hotspot will have less of a drain on your phone’s battery compared to the WiFi hotspot connection.
    As JURES (the original contributor of this temporary fix) had explained, you can re-install the MyDrive app onto your phone, sign in to it and use it for routing to send to your devices, but just don’t pair the Bluetooth within the app to your gps.

    Doug
  • Norrie83Norrie83 Posts: 4 [New Seeker]
    DougLap wrote: »
    Hi @Norrie83

    Try the following.

    Completely forget the TT units Bluetooth connections on the phone and also delete the connection on the TT unit. Having then turned both units Off and On then do the following bearing in mind not to open the My Drive App at any time.

    Go to Personal Hotspot in the iPhone Settings and turn it on.
    Go to Bluetooth settings in the iPhone and turn that on.
    Turn the TT unit on and go to Bluetooth in Settings and select add a phone
    When the TT unit appears in Bluetooth on the phone Tap it and then Tap the pairing numbers when they appear on the phone and TT unit

    The two units are now paired and you should get Traffic etc and also will probably get the handsfree working.

    The problem is as a result of a Security Change when Apple issued IOS13 and later which has stopped the My Drive App working as it should. Although you will not be asked for your Personal Hotspot Password during the pairing it is essential that you have both Bluetooth and Personal Hotspot On when you connect to the TT otherwise the connection will not happen.

    You will not get the messaging facility as that was what the My Drive App involvement was there for but that will not work and it appears a simple or major change to the App is not an option to resolve the issue.

    From now on only use the My Drive App for Route or My place creation etc as you would if in it on the PC.

    Here are details from another post of a suggestion made by @jures which has been successful.


    Here is an excerpt posted by JURES (another forum contributor) as a temporary fix for iPhones using iOS 13+ operating systems end of January -

    If you pair gps with iPhone without MyDrive app, traffic works flawlessly - perfectly!
    You can even install the MyDrive app afterwards and use it for routing - but - JUST DONT PAIR gps over the app!!!
    Traffic will still work, MyDrive routing will work, the only thing that does not work will be smartphone features (calls / sms) but thats not important on bike.

    Traffic and MyDrive under iOS 13+ works!!!!!
    - Delete MyDrive app on iPhone
    - Delete old Bluetooth pairings of gps on iPhone
    - Connect gps to iPhone over Bluetooth under standard way
    - Install MyDrive app
    - DO NOT pair gps over the app
    - have personal hotspot on iPhone turned ON just for Bluetooth and USB Only
    - DO NOT pair gps with WiFi of this personal hotspot

    TRAFFIC AND MY DRIVE WILL WORK NON STOP!!

    Problem is in the app (pairing through the app)

    Using the Bluetooth and USB Only pairing hotspot will have less of a drain on your phone’s battery compared to the WiFi hotspot connection.
    As JURES (the original contributor of this temporary fix) had explained, you can re-install the MyDrive app onto your phone, sign in to it and use it for routing to send to your devices, but just don’t pair the Bluetooth within the app to your gps.

    Doug

    I’ll go try this shortly...... if I’m following correctly then I’ll have to have a hotspot on my phone at all times when riding so I will get real-time traffic such as road block, mobile traffic cameras etc ?

  • Norrie83Norrie83 Posts: 4 [New Seeker]
    DougLap wrote: »
    Hi @Norrie83

    Yes you need to have the Personal Hotspot active as well as Bluetooth on your Phone. You will not be asked for the Personal Hotspots Password at any stage but it needs to be on.

    Doug

    Many thanks for the reply.

    With doing as you said above I have on this list

    Traffic - Connected

    MyDrive - Connected ( I’ve kept the app shut and not opened it at any time )

    Bluetooth - Not connected.
    When I open that it says my phones is connected and it’s showing connected in the Bluetooth setting on my phone.

    WiFi - connected. This is through my hotspot I’ve created.

    I also have my cardo freecom 4+ connected with Spotify also playing so phone and rider are working in tandem.

    I’m guessing with the above settings I have real time traffic and mobile cameras etc ?

    The sad thing is when I first set this up and took it out I had everything working and connected including MyDrive and I was getting text and able to hit the Siri button that’s now vanished.

    It’s a expensive unit to have to do so many work arounds.

    I’m feeling a bit tempted to return it and pick up the latest garmin and try that and see what one functions better.

    I just need live navigation and cameras any media stuff is a bonus.

  • DougLapDougLap Posts: 8,003
    Superuser
    edited August 2020
    Hi @Norrie83

    Firstly regarding the MyDrive App you do open that at any time during the pairing process as was originally defined before the IOS changes. Also you say you have Connected the personal hotspot to the Wifi which you also do not do.

    So the Pairing process should involve the following.

    Turn on Personal Hotspot on your phone whenever you Pair the phone to the TT unit via Bluetooth and when using Bluetooth with the TT unit. Do nothing else with it as all you need is for it to be on in settings not directly connected to the TT unit including NOT connected to its Wifi

    Turn on Bluetooth on the phone and TT unit and Tap Add a phone on TT. When the TT unit appears in Bluetooth on the Phone Tap it and then you get the Pairing numbers
    Which you accept on both units.

    Now the TT unit is paired without having involved the MyDrive App in the process. Indeed you could delete the App from your phone if you like unless you at anytime may want to use it just as you would the webpage on your PC.

    So you will have the following

    Bluetooth has to be on when connecting the phone to the TT during use when you need traffic etc but has only 1 entry for the TT unit Not 2 listed on the phone as you would have done had you involved MyDrive in the Process during the pairing process.

    Personal Hotspot has to activated on your phone when pairing and when using Bluetooth with the TT unit but NOT connected to the TT units Wifi. It just has to be on to enable the Bluetooth connection to the TT to work which may sound odd but it works. . If you were to turn the Personal Hotspot off when connected to the TT unit by Bluetooth you will lose the Bluetooth connection.

    MyDrive does not have to be open whilst the unit is connected by Bluetooth/Personal Hotspot and because you have not involve MyDrive in pairing process MyDrive messaging will not work.

    If you have received messages this maybe because you have connected the Personal Hotspot to the units Wifi but it will fail to maintain the messaging connection usually within seconds. Only ever turn MyDrive on if you want to create a route or A MyPlace. Messaging does not work.

    So redo the pairing as I suggested earlier with my above comments in mind.

    Doug
  • YamFazManYamFazMan Posts: 19,478
    Superusers
    edited August 2020
    Hi
    @Norrie83
    Welcome to the site....
    Norrie83 wrote: »
    I just need live navigation and cameras any media stuff is a bonus.
    A further option you may want to try....
    If you only need a basic Phone and Data Connection....
    You don't need the MyDrive App with its bells & whistles... Just a Straight simple Bluetooth Connection
    Note... I always set up the Headset 1st Phone 2nd
    Setting up the Phone....
    Tap 4Dot (.... Menu) --> Setting --> Bluetooth --> Add Phone
    Scroll the screen to display the Question mark Icon ( ? ) Screen bottom right
    Tap on the ( ? ) Question mark Icon....
    Select... Not interested in all of these features
    Connect without the MyDrive App

    Follow the on screen instructions... To connect over basic Bluetooth

    Also see... https://discussions.tomtom.com/en/discussion/comment/1669861/#Comment_1669861

    ATB YFM
  • Norrie83Norrie83 Posts: 4 [New Seeker]
    DougLap wrote: »
    Hi @Norrie83

    Firstly regarding the MyDrive App you do open that at any time during the pairing process as was originally defined before the IOS changes. Also you say you have Connected the personal hotspot to the Wifi which you also do not do.

    So the Pairing process should involve the following.

    Turn on Personal Hotspot on your phone whenever you Pair the phone to the TT unit via Bluetooth and when using Bluetooth with the TT unit. Do nothing else with it as all you need is for it to be on in settings not directly connected to the TT unit including NOT connected to its Wifi

    Turn on Bluetooth on the phone and TT unit and Tap Add a phone on TT. When the TT unit appears in Bluetooth on the Phone Tap it and then you get the Pairing numbers
    Which you accept on both units.

    Now the TT unit is paired without having involved the MyDrive App in the process. Indeed you could delete the App from your phone if you like unless you at anytime may want to use it just as you would the webpage on your PC.

    So you will have the following

    Bluetooth has to be on when connecting the phone to the TT during use when you need traffic etc but has only 1 entry for the TT unit Not 2 listed on the phone as you would have done had you involved MyDrive in the Process during the pairing process.

    Personal Hotspot has to activated on your phone when pairing and when using Bluetooth with the TT unit but NOT connected to the TT units Wifi. It just has to be on to enable the Bluetooth connection to the TT to work which may sound odd but it works. . If you were to turn the Personal Hotspot off when connected to the TT unit by Bluetooth you will lose the Bluetooth connection.

    MyDrive does not have to be open whilst the unit is connected by Bluetooth/Personal Hotspot and because you have not involve MyDrive in pairing process MyDrive messaging will not work.

    If you have received messages this maybe because you have connected the Personal Hotspot to the units Wifi but it will fail to maintain the messaging connection usually within seconds. Only ever turn MyDrive on if you want to create a route or A MyPlace. Messaging does not work.

    So redo the pairing as I suggested earlier with my above comments in mind.

    Doug

    I’m really confused at the start you are saying don’t connect to a hot spot and the next saying to connect to a hotspot ?

    Has anyone heard any rumours of Tom Tom addressing these issues ?
    It a been around for 2 years so the developers should be able to get a fix out.

    I’d like to have the features advertised but seems that not all of them will work.

    I’ve only had it here days and tempted to take it back and get the new Garmin Zumo XT as not seeing as many problems with that unit.

  • kieronkieron Posts: 472
    Superusers
    edited August 2020
    Hi there Norrie83 -

    DougLap is stating that in your iPhone Personal Hotspot settings not to use the “Turn on WiFi” but to use the “Bluetooth and USB only”.
    I'm currently using my Rider 500 and iPhone 7 Plus this way and gives me the traffic and safety camera requirement.
  • DougLapDougLap Posts: 8,003
    Superuser
    edited August 2020
    Hi @Norrie83

    When you normally connect a device to your IPhone via Bluetooth you normally only think of turning the Bluetooth on in Settings. Then when you use the Bluetooth pairing you only think to have Bluetooth on in settings.

    The unusual thing here is that whenever you turn Bluetooth on either when pairing or when using the TT device once paired you also need to have the Personal Hotspot turned on in Settings. Ie just showing as turned on in settings nothing else.

    At no point do you connect your iPhone to the TT unit by inputting your Personal hotspots password and at no point does it show on the TT unit as connected to the TT’s Wifi.

    Doug
  • maddscotmaddscot Posts: 1 [New Seeker]
    tried this an no go, it seems it was once connected, but the iOS update to 13+ broke it. Now it does not pair (hotspot on or off). this should be a top priority for Tom Tom as without many features are not available... May sell this and go back to Garmin or just use the phone, but wish to have the glove friendly use (phone gloves really dont work well) and viewing as well as weather proofing. Shame as I was liking this unit at the price point too.
Sign In or Register to comment.

Who's Online in this Category0