Purchased full map over week ago but still not showing to download — TomTom Community

Purchased full map over week ago but still not showing to download

Tazz27Tazz27 Posts: 3 [Novice Seeker]
edited August 2020 in Map purchasing
Hi Guys
I purchased a full map of Australia to download and install on my VIA 1415 device as it has only USA map on it at the moment , i have updated and soft reset device several times like many other questions are told to do but still not showing in my content to download ..any help greatly appreciated :)

Best Answer

Answers

  • DougLapDougLap Posts: 7,993
    Superuser
    Hi @Tazz27

    Contact Customer Support. Try this as there are no Phone lines with so many working from home. .

    Go to the bottom of this page and Select Contact Us under the heading Support
    Log into the Page that opens
    Tap on the Red Contact Us
    Type Help in the Red box and hit return
    Help Box appears with a number of suggestions. Select Contact Us at the bottom of the box.
    You now get a box with Chat/Email. options

    The chat facility is very busy so you may have to try a few times before you get a connection.

    Doug
  • Tazz27Tazz27 Posts: 3 [Novice Seeker]
    Thank you Doug ..i have tried to contact customer support several times already but will keep trying ..was hoping to have unit usable by now...will see what happens
  • Tazz27Tazz27 Posts: 3 [Novice Seeker]
    thank you Vikram and Doug for your help ..i have now installed maps all good
    Cheers guys =)
  • DougLapDougLap Posts: 7,993
    Superuser
    Hi @Tazz27

    Glad you are sorted.

    Doug
Sign In or Register to comment.

Who's Online in this Category0