Traffic alerts not activated — TomTom Community

Traffic alerts not activated

Hi all,
On the 16/07/2020 I purchased a subscription for the live TomTom traffic updates and two days later it is still not activated on my device. I am very confused as to what is happening. I would be extremely grateful if someone could help me out.

Answers

  • YamFazManYamFazMan Posts: 17,689
    Superusers
    edited July 18
    Hi
    @Yashpal_S_
    Welcome to the site....
    The restrictions as a result of the Coronavirus, Social Distancing and people working from home, are probably delaying the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up on Monday and check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • VikramKVikramK Posts: 10,424 Moderator
    Hi @Yashpal_S_

    I don't see the service has been activated for the device yet. Please contact the customer service with the order number, and they should be able to sort it for you...

    Regards
    Vikram
  • TeBeCeTeBeCe Posts: 6 [Apprentice Traveler]
    Good luck with that. Same problem here. I am contacting them for 11 days now and still no answer....
  • Yashpal_S_Yashpal_S_ Posts: 2 [Apprentice Seeker]
    @VikramK
    I attempted to contact customer service on
    020 7949 0132 from there I learnt that I should contact them through email or the website. Are there any other number where I can contact customer support, and if not what email should I use to address my issue.
    Regards Yashpal
  • VCPPVCPP Posts: 2 [New Traveler]
    Hello,
    i have paid approximately 30 eur for "TomTom Traffic, LIVE- and other Services". The payment was accepted and the date on my device changed from 2020 to 2021, so initially everything was ok. I could use the services for 2 weeks and then it failed again. The date was again changed to 2020 and i was unable to use the services. I have searched for several mail-addresses but every time i sent a mail an automatic answer showed up.. Also the telephone numbers are not working.. Does anyone have the same problem ,or even better, know a solution? Thank you in advance. Kind regards.
Sign In or Register to comment.

Who's Online in this Category0