Our servers are very busy right now - Can't update lifetime maps on my Start 25

Simon-W Registered Users Posts: 3
New Seeker
Hi there,
I tried to update my device multiple times. I am on windows 25 but it says 'getting ready' and eventually hits the

Our servers are very busy right now
Click Retry a few times until you are connected. If that doesn't work, close MyDrive Connect and start it again.


Tried doing a 20 second on/off button reset on the device, and of course unplugging and restarting MyDrive Connect. Any one know how to allow this to update?

I tried all yesterday and get the same page



  • YamFazMan
    YamFazMan Posts: 20,998
    edited July 2020
    Welcome to the Site....
    If I have a problem with MyDrive Connect... I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program gives MyDrive Connect a CPR and brings to bring it back to life...
    Method See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDrive Connect) and deleted them. Hurrah!… that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.
    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    Stay Safe... ATB YFM
  • Simon-W
    Simon-W Registered Users Posts: 3
    New Seeker
    Thanks @YamFazMan appreciate you trying to help out. I am on a PC
    I deleted all folders in


    and followed the steps as per the other thread

    I initially struggled to get rid of this file:
    C:\Users\simon\AppData\Local\TomTom\MyDrive Connect\QtWebEngine\Default

    but once i did by 'ending task' in task manager

    I started up MyDrive Connect again and it was as if I had installed it fresh. Logged in and it's now


    Keep your device connected and this app open while updating.

    with a percentage progress bar showing and all seems to be fine

    Thanks again for fixing this for me!


  • Simon-W
    Simon-W Registered Users Posts: 3
    New Seeker
    Dammit, so it downloaded and now has been stuck on this page for hours

  • DougLap
    DougLap Posts: 9,956
    Hi @Simon-W

    I wonder if you PC has USB power saving activated and so has turned the socket off.

    Not the recommended procedure but I have found pulling the USB connecter out of the PC and reinserting it can resolve. Up to you.