When I tried to update my old Start 60 it won't connect to my PC via USB

folateman Registered Users Posts: 3
Apprentice Seeker
I replaced my Start 60 (now used by my wife) with a Go. The start 60 will not connect via USB to my PC in order to install the visible updates. I have tried several cables but without success.


  • YamFazMan
    YamFazMan UKPosts: 21,335
    edited July 2020
    Welcome to the Site....
    If I have a problem with MyDrive Connect... I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program gives MyDrive Connect a CPR and brings to bring it back to life...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDrive Connect) and deleted them. Hurrah!… that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    Stay Safe... ATB YFM
  • folateman
    folateman Registered Users Posts: 3
    Apprentice Seeker
    Thanks I tried this but unfortunately it didn't work. The Start 60 recognises it is connected to a PC (shows the icon) but comes with the message '... all you have to do is go to tomtom.com/getstarted. When I login to MyDrive it still shows the updates but they are greyed out with the message connect your device to see the latest status etc.
  • folateman
    folateman Registered Users Posts: 3
    Apprentice Seeker
    After a series of uninstalls with re installs with progressive modifications each time eventually I have now managed to update the Start 60. In the end the route described for Windows 10 issues elsewhere on this platform worked. This involved Revo Uninstaller to remove the files followed by all the registry entries etc left behind followed by clearing the browser cache. It took some time but success at last. Thanks again for the suggestions.on these pages.