TomTom Professional 6200 live traffic not connecting

Neil_Ridley
Neil_Ridley Registered Users Posts: 2
Novice Seeker
Hi there I’m setting up 6200 but cannot seem to get live traffic to connect at all. It says I have a lifetime traffic subscription but on the mydrive app it always says unavailable for subscription yet displays an expiry for speed cameras. Everything else seems to work fine just the traffic.

Answers

  • DougLap
    DougLap Posts: 10,122
    Superuser
    Hi @Neil_Ridley

    Hopefully @VikramK can check your account settings. Look back here later.

    Doug
  • VikramK
    VikramK Administrators Posts: 14,580
    Moderator
    Hi @Neil_Ridley

    Welcome to the community!

    The services for Traffic have not been activated yet, please do a factory reset and log-in again to TomTom services.

    Factory reset-
    Main menu- Settings- System- Reset device.

    Regards,
    Vikram.
  • Neil_Ridley
    Neil_Ridley Registered Users Posts: 2
    Novice Seeker
    Hey there all seems to be working now thank you so so much for that!
  • Ronseal
    Ronseal Registered Users Posts: 1
    New Seeker
    edited July 2020
    hi there i have 6200 go professional....my tomtom traffic expired on the 13/07/2020 I have purchased the speed camera and tomtom traffic today and I have tryed everything before posting up on here and it still says they are both expired and I have had it on charge and connected to WiFi please help 🙂
  • DougLap
    DougLap Posts: 10,122
    Superuser
    HI @Ronseal

    Contact Customer Support .No phone line available with many working from home.

    https://discussions.tomtom.com/en/discussion/1124472/contacting-customer-services/p1

    Doug