Lifetime traffic & speed camera updates not working — TomTom Community

Lifetime traffic & speed camera updates not working

I have recently upgraded to a Go premium 6 bought direct from Tomtom and the device is supposed to have lifetime traffic & speed cameras.

My issue is that when i go onto system, about and then subscriptions its shows that my traffic and speed camera’s will expire at the end of the month!

Does anyone know why it shows an expiry date if its supposed to be lifetime?

Thanks

Best Answer

Answers

  • DougLapDougLap Posts: 6,597
    Superuser
    Hi @Glenno1882

    Maybe @VikramK can check your settings on the TT servers and report back tomorrow.

    Doug
  • LochfrassLochfrass Posts: 13,142
    Superusers
    HI

    Please contact Support to solve this. They must make changes on their servers

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    If phone support is closed due to the pandemic, try the chat
    United Kingdom
    Chat: https://uk.support.tomtom.com/app/contact/p/5007/c/4757#ChatTab
    Monday - Friday: 09.00 AM - 05.30 PM BST
    Saturday - Sunday: Closed
  • LochfrassLochfrass Posts: 13,142
    Superusers
    Hoops. Doug was faster =)
  • Glenno1882Glenno1882 Posts: 4 [Apprentice Traveler]
    Cheers guys i will give them a call this morning
  • Glenno1882Glenno1882 Posts: 4 [Apprentice Traveler]
    VikramK wrote: »
    Hi @Glenno1882

    Welcome to the community!

    I have asked the team to make some changes in the backend. Just do a soft reset and check for updates now.



    Regards
    Vikram

    Thank you Vikram your a star mate?
  • IrisGranubandIrisGranuband Posts: 1 [New Seeker]
    I have the same problem with my Trucker 620. It is supposed to have lifetime traffic but now it has expired.
    Can somebody please help me too?

    Thanks
  • DougLapDougLap Posts: 6,597
    Superuser
    Hi @IrisGranuband

    Hopefully @VikramK can check your account settings and sort them out if necessary. Look back here tomorrow.

    Doug
  • VikramKVikramK Posts: 10,585 Moderator
    Hi @IrisGranuband

    Welcome to the community!

    I find there are several devices linked to your TomTom account. Could you send me the serial number through a PM, please?

    Thanks, Vikram
  • Cristian3006Cristian3006 Posts: 1 [New Seeker]
    edited May 20
    Hi! i have problem with my TomTom GO Professional 520 with traffic service(not working) even though it is active lifetime. i tried resseting the device but nothing happened.
    Thanks
  • VikramKVikramK Posts: 10,585 Moderator
    edited May 21
    Hi @Cristian3006

    Welcome to the community!
    Have you paired the device with a compatible smartphone? I would recommend that you see the steps in the video below-



    Also, see the troubleshooting steps on this FAQ-
    https://uk.support.tomtom.com/app/answers/detail/a_id/10316

    Regards,
    Vikram
  • Marcel123Marcel123 Posts: 3 [Apprentice Seeker]
    Lifetime traffic & speed camera updates not working:

    I have a Go Premium and did a soft reset to my system and I did go to the updates but my system is already up to date. Although still no traffic and speed camera's. Can anyone help me solve thia problem?
  • YamFazManYamFazMan Posts: 18,000
    Superusers
    Hi
    @Marcel123
    Welcome to the site....
    The restrictions as a result of the Corona Virus, Social Distancing and people working from home, is probably delaying the Activation of Accounts and the Allocation of Maps & Services to Accounts/Devices....
    On Monday @VikramK or @lampard the Forum Moderators should pick this up and check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • VikramKVikramK Posts: 10,585 Moderator
    Hi @Marcel123

    Welcome to the community!

    I have asked the team to make some changes in the backend. Just do a soft reset and check for updates now.



    Regards,
    Vikram
  • Marcel123Marcel123 Posts: 3 [Apprentice Seeker]
    Thanks for you help Vikram. The traffic and speed camera's are activated again. I have 2 other strange things. When I go to Menu, instellingen, system, Info, I see GPRS-status "no connection" . I can't see what my SimID or Mobile number in de TomTom Go Premium is. It looks to me that "no connection" is not right.

    The second strange thing is that I can connect my own mobile with the TomTom via BlueThooth (for answering calls) but I can't connect it anymore with the MyDrive v2.7.0 app on my Huawei P20 mobile phone.

    Can you help fix both problems?
  • DougLapDougLap Posts: 6,597
    Superuser
    Hi @Marcel123

    Re the GORS idf the unit is connected to your Wifi then the GPRS is disconnected. If you go out of range of the Wifi it should then connect.

    Regrading the Huawei phone there have been a few comments of issues with that make maybe if you contact Customer Support they may be able to answer you. Unfortunately during the current situation phone contact is not available but chat or email may be used as follows:-

    https://discussions.tomtom.com/en/discussion/1124472/contacting-customer-services

    Doug
  • Marcel123Marcel123 Posts: 3 [Apprentice Seeker]
    That's logical. Thanks for you're help Doug.
This discussion has been closed.

Who's Online in this Category0