I have a GO Premium and I cannot make MyDrive Connect work with it — TomTom Community

I have a GO Premium and I cannot make MyDrive Connect work with it

enzocontinienzocontini Posts: 7 [Apprentice Seeker]
edited June 5 in MyDrive Connect
I have updated GO Premium connecting it directy with a WiFi but I tried to see how to do it using TomTom MyDrive Connect.
However, even though when logged the navigator is shown in the list of devices, when I connect it with USB to my Surface Pro PC I got a pop-up windows appear with
HEADING
sub_title
message
?How_to_text

message_disconnect

... and I cannot do anything other than disconnect the device and return to the device list in MyDrive Connect SW.

What is wrong? What can I do to make that SW work with my GO Premium navigator?

8izh52j9qvo0.jpg
5ek6ljj7pv05.jpg


Best Answer

Answers

  • YamFazManYamFazMan Posts: 17,712
    Superusers
    edited June 5
    Hi
    @enzocontini
    Welcome to the site....
    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed
    ________________________

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu... You will need to edit the Registry before the USB Selective Suspend menu will display (See Note... (4) below)

    Laptop users also see Note (1) (2) (3) & (4)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu

    kt9idp9azgzl.jpgNote...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    Note... (3) Thanks User 333....
    (Quote)... Just had a similar problem with new Dell XPS 13 7390 (running Windows 10) which only comes with USB-C port. Found that I was able to update my TomTom Via 225 (using a supplied USB-C to USB-3 cable/hub) only after changing this setting in Windows 10:
    Settings - Device - USB - Un-tick this box: 'Stop devices when my screen is off to help save battery'
    If you're having problems with connected devices, clear the check-box (End Quote)

    Note... (4) Editing the Registry... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855
    ________________________________

    Also....
    ________________________________

    If I have a problem with myDrive Connect... instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect CPR to bring it back to life...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    Stay Safe... ATB YFM
  • YamFazManYamFazMan Posts: 17,712
    Superusers
    Hi Again....
    @enzocontini

    The NAV5 (Wi-Fi) devices normally update using Wi-Fi....
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    See Option... (2) Connect over USB....


    TomTom Video... Updating your navigation device using Wi-Fi®



    If you have successfully connected your device to your Wi-Fi....
    To check your Connection Speed, Signal Strength & Quality
    On the Device... Tap 4Dot (.... Menu) --> Settings --> Wi-Fi
    Tap on the Your Wi-fi name (The one Showing as connected)
    A new Menu Page opens

    7g8gwfpx1swt.jpg
    On the left-hand side of the screen is your Wi-Fi Connection Status

    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps
    Tomtom NAV5 (Wi-Fi) devices will only connect to a 2.4GHz Wi-Fi network
    All the update actions are executed on the device...

    ___________________________

    Option... (1) Connected Wi-Fi
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps

    I always update my devices one Update at a time
    The NavCore Application and QuickFixGPS updates are force ticked by Tomtom... Deselect any other updates like Maps, Speed Cams etc... Update the mandatory item/s first, when complete update the remaining items one at a time

    Note... NAV(5 Wifi) devices connected over Wifi do not require MyDrive Connect to be running Even if myDrive is running you have no access the MyDrive Connect menu structures as used by the previous NAV3 & 4 devices
    ____________________________

    Option... (2) Connected USB
    If Wi-Fi is not available or is slow/unstable/unreliable.....
    Tomtom recommend a minimum Wi-Fi download speed of 30Mbps

    Connecting hard-wired over USB is normally more reliable than any Over The Air Connections
    Updating your new device over USB will require "MyDrive Connect"
    Get it here..... https://uk.support.tomtom.com/app/answers/detail/a_id/12428
    Install and Run MyDrive Connect
    There's no need to login to MyDrive Connect... See Note... (1)
    Connect your Device to a USB Port on your PC
    The Update will hopefully complete

    If your using a Laptop it would be also more advisable to use a hard-wire connection back from the Laptop to the Router....
    _________________________

    Note... (1) MyDrive Connect will only show a "Splash screen" saying "Connect your device using Wifi" etc....

    27bxc59f2s23.png
    If required you can close the 'Main Mydrive Window' showing the "Connect your device using Wifi" Splash screen... MyDrive Connect only needs to run in the background on the PC TaskBar... The NAV(5 Wifi) devices have no access the MyDrive Menu structures as used by the previous NAV3 & 4 devices
    Updating a NAV5 (Wi-Fi) device using USB is the same as using Wi-Fi, all of the update actions are executed on the device...
    Tap the 4Dot(.... Menu) --> Setting --> Updates & New Items
    Extra Maps are Installed/Maintained... Tap the 4Dot(.... Menu) --> Setting --> Maps

    ATB YFM
  • enzocontinienzocontini Posts: 7 [Apprentice Seeker]
    edited June 6
    Thank you.
    But what I see in MyDrive Connect, when the device is connected to the PC, is not what you show (it should be understandable to me) but this incomprehensible screen:

    8izh52j9qvo0.jpg

    Moreover, why looking into my profile in TomTomsite it is shown an update available for my device related to Charging Station and, on the contrary, looking in the updates section of GO Premium it is said that it is all updated?
    80umozhb7j8j.jpg
  • DougLapDougLap Posts: 6,355
    Superuser
    Hi @enzocontini

    Historically there have been issues with Surface pro units which if you look at the following says the Tomtom had not designed with the Surface pro in mind. You will see that a solution was found for connecting . Certainly I have never seen anyone else post a similar screen image to the one you have.

    https://discussions.tomtom.com/en/discussion/968783/go-500-random-disconnections-on-surface-3-pro

    Certainly if you have a Mac or PC you get the screen that @YamFazMaWifi has shown with no access to details of what the Wifi models have loaded or what updates are available. The PC with My Drive Connect running is only an avenue to the internet if you have no Wifi, maybe for medical reasons, or the download speed is slowish and you have to use the menu on the Wifi unit to manage what you want t do as there is no way to manage on the PC.

    If you Tap Settings/ System/About on your Premium you can see your ci=ureent Map and Op versions etc but it does not detail what Charger Station version you have.

    Doug
  • enzocontinienzocontini Posts: 7 [Apprentice Seeker]
    edited June 6
    Thank you. I tried to connect the device GO Premium to another "normal" Windows 10 PC and the screen shown in MyDrive Connect, attaching the device via USB) is exactly the same I had on my Surface Pro 6. So it is not a matter of Surface but of MyDrive Connect related to my GO Premium device ...
  • YamFazManYamFazMan Posts: 17,712
    Superusers
    Hi
    @enzocontini
    Did you try.....
    If I have a problem with myDrive Connect... instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect CPR to bring it back to life...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________

    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.


    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    Stay Safe... ATB YFM
  • enzocontinienzocontini Posts: 7 [Apprentice Seeker]
    Thank you YamFazMan for the suggestion. However in my case nothing changed even trying your suggested procedure! :-(
  • enzocontinienzocontini Posts: 7 [Apprentice Seeker]
    Rob_R your answer was very exhausting! I verified all that you said happened to me too. Anyway, the strange notification I receive in the popup box seems to be a littler bug that TomTom developers should solve in next MyDrive Connect release ... ;-)

    Thank you
Sign In or Register to comment.

Who's Online in this Category0