TT Go 6200 Stopped Working

Doug425 Registered Users Posts: 3
Apprentice Seeker
edited December 2021 in Devices using Wi-Fi®
My TT Go has stopped working after the last update. It now constantly reboots itself (with a drum roll) until a graphic on the screen indicates that you should connect the unit to a PC. When you connect it to a PC, a box appears stating that it's resetting the device with a percentage complete indicator. Once it hits a 100%, which takes around 10 minutes, the device reboots with a drum roll 2 or 3 times then the graphic indicating that you should connect it to the computer appears again! Any advice very welcome and would be gratefully received. :-)


  • VikramK
    VikramK Administrators Posts: 14,549
    Hi Doug425

    Welcome to the community!

    Had you tried the restore process at some point -

    I don't see any problems in the backend. My suggestion would be to contact customer service and seek further advice. The technicians would be able to have a better look.

    Regards, Vikram
  • martinS1970
    martinS1970 Registered Users Posts: 1
    New Seeker
    I was wondering if this problem solved yet, cause my TT Go 520 WiFi has the same problem after an invalid update. Continuous repairing itself at 100% and then the "connect"graphic appear again instead of restarting de TT.1vwjrxiwuc75.jpg
  • Doug425
    Doug425 Registered Users Posts: 3
    Apprentice Seeker
    I’m afraid the advice given by Vikram hasn’t helped as I still have the same problem. Pretty disappointed TBH and not sure what to do next.
  • Doug425
    Doug425 Registered Users Posts: 3
    Apprentice Seeker
    Has anyone got any further suggestions on how to solve this problem? I've tried contacting TT by phone but I get a recorded message stating that their office is closed due to C-19. Can anyone suggest a way forward?
  • MarcoB78
    MarcoB78 Registered Users Posts: 1
    New Traveler
    Same problem on my 6250...
  • Grandadsue
    Grandadsue Registered Users Posts: 1
    New Seeker
    Has this problem been resolved yet - having the same issue