My Drive not connect device — TomTom Community

My Drive not connect device

Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
Hi, I have now tried with two different laptop and I have same issue with both. I try to update my TOMTOM 400 navigator and when coputer hve upload new software it constantly disconnect navigator. Also I have lost all maps from navigator and I am not able to upload maps again. Whan can I do?

Answers

  • YamFazManYamFazMan Posts: 20,278
    Superusers
    edited April 2020
    Hi
    @Markku_M1
    Welcome to the site....
    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074
    ______________________

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program... To be just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\
    _____________________

    Download/installation interrupted
    (1)... Are your USB ports set for power saving "USB Selective Suspend"
    (2)... Random Disconnects on Surface Pro 3 & 4
    See... https://discussions.tomtom.com/en/discussion/comment/1694455/#Comment_1694455
    ______________________
    ______________________

    Also see....
    Some Maps are now to big to install onto the the on-board Memory....

    Important See Catch22... https://discussions.tomtom.com/en/discussion/comment/1686043/#Comment_1686043
    ATB YFM
  • LochfrassLochfrass Posts: 16,694
    Superusers
    Wich Pc System do you have? A Surfacebook?
  • Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
    hello YamFazMan, I have tried several times to uninstall/re-install MyDrive but still I have not succeed. I can upload all new SW to computer but not from computer to navigators. I have tried with my motorcycle navigator and car navigator and same issue with both navigators. MyDrive inform no connection too navigator.
  • LochfrassLochfrass Posts: 16,694
    Superusers
    Lochfrass wrote: »
    Wich Pc System do you have?

  • Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
    I have windows 10, but I have also tried with Mac without success

  • Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
    every time same thing, navigator does not reply
    3z9uh8ctzr76.png
    it start update but it will stay at 4% until inform navigator does not reply
  • Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
    I have to say that I am very unhappy to TomTom technical support. i have now around 3 weeks, several times tried to update my TomTom 400 motorcycle navigator and only result I have succeed is I lost maps. Support from chat site is minor and I do not even know where I can send or bring navigator for service. maybe this is TomTom marketing policy to get people update their navigator every second year.
  • YamFazManYamFazMan Posts: 20,278
    Superusers
    edited April 2020
    Hi
    @Markku_M1
    I'm Running Win10 as well... All OK no problems....

    Try.... With MyDrive Connect running... Your device plugged in and turned on
    On the PC keyboard... Press the Windows Button + X key
    Choose Device Manager
    The Device Manager Window opens
    Double Click on the '>' character to the left of Network adapters
    The Network adapters Menu opens

    npfdr7vqvb2y.jpg
    If the Tomtom#'n' Icon or the Remote NDIS Compatible Device Icon (See Note 1) has a Yellow Exclamation displayed then there is a problem with the installed Driver....
    Note 1... The Driver maybe listed as a Remote NDIS Compatible Device....
    My GO Premium displays as 'NDIS Compatible Device #8'
    ____________________

    Maybe Win 10s Troubleshooter will fix the Driver Problems (Or any other USB problems)

    With MyDrive Connect running... Your device plugged in and turned on
    On the PC keyboard... Press the Windows Button + R key
    In the Run box type... Control printers
    Click OK
    The Devices and Printers window opens
    Right Click on the Tomtom Icon and select 'Troubleshoot'
    Note... Maybe listed as a Remote NDIS Compatible Device....
    My GO Premium displays as 'NDIS Compatible Device #8'

    neha7jky70on.jpg
    Then follow on-screen instructions....

    ATB YFM
  • Markku_M1Markku_M1 Posts: 6 [Apprentice Seeker]
    Thanks YFM,

    I did all you mentioned and I receive following trouble shooting message
    "Remote NDIS Compatible device can`t work with USB 3.0"

    What to do next?
  • YamFazManYamFazMan Posts: 20,278
    Superusers
    edited May 2020
    Hi
    @Markku_M1

    See if there are any updated drivers for your USB 3.0 Ports
    Also don't use an USB Hub, connect direct to the computer

    USB 3.0 is supposed to be backward compatible to USB 2,0 but some makes of USB 3.0 ports are more backward compatible than others

    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0