MyDrive Connect Waiting for your device...

KevinPeters Registered Users Posts: 2
New Seeker
And waiting and waiting...

I am trying to install a map on my Go 400, anything that will fit on the internal memory, in this case the Soiuth West europe map. When I start the process I just get a message on MyDrive saying: "Waiting for Device" and on the device it says "Updating - do not disconnect your device". This goes on for hours with nothing happening. I have tried two different Macs, with a hub, without a hub, different cables, I have updated to the latest version of MyDrive, cleared my cache... Sometimes I am amazed that TomTom still manage to exist with shoddy engineering like this.

Anyway, I would love to put a map on my Go-400. Any suggestions from TomTom?


  • KevinPeters
    KevinPeters Registered Users Posts: 2
    New Seeker
    I've also tried: a factory reset of the device, putting the old SD card back in the slot, using a Windows 10 machine, removing the device from my account a re-adding it.

    It even hangs now on Your Device is Being Added.

    Shoot me now.
  • YamFazMan
    YamFazMan UKPosts: 21,359
    Welcome to the site....
    If I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here...

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.
    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

  • Quartz
    Quartz Registered Users Posts: 0
    New Seeker
    Am attempting to update my GO 5100 using MyDrive Connect on a MacBook Air with Big Sur 11.3.1. For the last several hours, the MyDrive screen has displayed a message 'Waiting for your device', while the GO 5100 screen is displaying 'Updating', 'Do not disconnect your device'. Is this normal? - and if so how long might the update take? Or alternatively, has the process stalled, in which case what can I do to redeem the situation?
  • JudyYW
    JudyYW Registered Users Posts: 0
    New Seeker
    edited July 2021
    Hi everyone,

    My device is GO5000. I was trying to update my device, my laptop can download the updated map however it got stuck at 'waiting for the device' in MyDrive Connect even the device screen is showing it's connected to my laptop.

    I left my laptop (Mac) for hours when I went to bed and in the morning nothing had updated. This is the first time I download MyDrive Connect into my mac as well.

    Does anyone have this problem?
  • endofmytether
    endofmytether UKRegistered Users Posts: 3
    New Seeker
    I have logged a ticket (with screenshots and attached logs) about this but not had any response.

    I need an update to the full 3D/buildings UK and Republic of Ireland maps. Don't need the rest of Europe (though have it installed currently).

    I am unable to update the map on my Tomtom Go 5000 but after seeming to download the map update, it then will not install, and hangs on "waiting for your device".

    Get the same problem on both Windows and Mac (with admin rights). On Windows the 'waiting for device' message remains on screen until you disconnect it, but on the Mac it times out after about 10 minutes with an error in MDC that it cannot find the device, even though on the device it says it is connected.
    It seems a common issue, and none of the suggestions I have read have fixed it. I work in IT, but am at the end of my tether with this thing and am ready to stamp it to death, though I am sure the problem is the software and not the hardware.

    Have tried -
    -Clearing cache
    -Ticking/unticking the option in settings to download updates to computer, numerous times
    -Reinstalling MDC
    -Different USB cables
    -Disabling USB sleep.
    -2 factory resets
    -Numerous restarts of device and computer
    -Adding a 32gb SD card (even though it should not be out of space - there are no errors to that effect, and there is 612 mb free)
    -Considered removing the map altogether and starting from scratch, though did not proceed as it came up with a dire warning that suggested I might be left with a brick.


  • endofmytether
    endofmytether UKRegistered Users Posts: 3
    New Seeker
    OK, found the solution here

    - Go to 'My Content' and select my active map
    - Instead of 'Update', select 'Change'
    - Reselect the existing map, and install it (which installed it onto the SD card)
    - Delete the out of date map from the device.

    Device is now showing there is insufficient memory to reinstall the new map back onto it, so I guess this was the cause of the issue, though it did not bring up any errors to that effect initially.