Go 60 will not go into Recovery mode — TomTom Community

Go 60 will not go into Recovery mode

I have a GO 60 which was lost in a house move. I finally came across after about 2/3 years and would not start up.
I have tried many times to get it into Recovery mode.
I get to the "drum-roll" and then "black and white text" DOS screen.
Tap the On/Off 1-2-3, then it just goes straight back to the "TomTom.." logo screen.
No wheels or cogs.

I have tried all sorts of speeds for the 1-2-3 with the same outcome... No Recovery

Any ideas ?

Please can someone help ?

Answers

  • YamFazManYamFazMan Posts: 17,087
    Superusers
    edited April 14
    Hi
    @NigelCurry
    Welcome to the site...
    Charge the device for at least 3 Hours... preferably With a USB Mains Charger
    You also need MyDrive connect running on your PC
    Here... https://uk.support.tomtom.com/app/getstarted/p/3821

    ATB YFM
  • NigelCurryNigelCurry Posts: 3 [New Seeker]
    Thank you YamFazMan, but that doesn't help.
    I only have the TomTom logo at the start page and when plugged into the pc with the MyDrive opened, it is not recognised as Connected.
    I need it to get into Recovery Mode, but as yet... no cogs or wheels on the screen..

    Can anyone please help
  • YamFazManYamFazMan Posts: 17,087
    Superusers
    HI
    @NigelCurry

    My Drive Connect MUST be Installed and Running on your PC and capable of showing Connected before Recovery Mode will work....
    _________________________

    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074
    ______________________

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program... To be just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214
    ______________________

    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.


    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0