Go 60 will not go into Recovery mode

NigelCurry Registered Users Posts: 3
New Seeker
I have a GO 60 which was lost in a house move. I finally came across after about 2/3 years and would not start up.
I have tried many times to get it into Recovery mode.
I get to the "drum-roll" and then "black and white text" DOS screen.
Tap the On/Off 1-2-3, then it just goes straight back to the "TomTom.." logo screen.
No wheels or cogs.

I have tried all sorts of speeds for the 1-2-3 with the same outcome... No Recovery

Any ideas ?

Please can someone help ?


  • YamFazMan
    YamFazMan Posts: 21,015
    edited April 2020
    Welcome to the site...
    Charge the device for at least 3 Hours... preferably With a USB Mains Charger
    You also need MyDrive connect running on your PC
    Here... https://uk.support.tomtom.com/app/getstarted/p/3821

  • NigelCurry
    NigelCurry Registered Users Posts: 3
    New Seeker
    Thank you YamFazMan, but that doesn't help.
    I only have the TomTom logo at the start page and when plugged into the pc with the MyDrive opened, it is not recognised as Connected.
    I need it to get into Recovery Mode, but as yet... no cogs or wheels on the screen..

    Can anyone please help
  • YamFazMan
    YamFazMan Posts: 21,015

    My Drive Connect MUST be Installed and Running on your PC and capable of showing Connected before Recovery Mode will work....

    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here... https://discussions.tomtom.com/en/discussion/comment/1682074/#Comment_1682074

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program... To be just as effective for giving MyDrive Connect a CPR...
    See... https://discussions.tomtom.com/en/discussion/comment/1686214/#Comment_1686214

    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.

    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\