TomTom Rider 550- Black screen during navigation — TomTom Community

TomTom Rider 550- Black screen during navigation

s4ppas4ppa Posts: 1 [New Traveler]
edited September 2019 in RIDER
I've recently got the 550 Rider but it's giving me problems.

It keeps powering off then back on all by itself, it also changes orientation without moving the device & riding the bike in a straight line, it'll power off then some items will come back on then the map will follow after, quite a few seconds later. All these issues started right from the off, brand new & installed on me bike.

I've tried the power lead that was already hard wired into the loom, I've tried wiring it straight to the battery, I've tried no external power whatsoever, just battery, still has the problems. I've changed the locking docking station as I narrowed it down to that, still problems, however, when the 550 is in me car, normal windscreen mount with power lead from the back & to the cigarette lighter, it doesn't have any problems...…….

Does anyone have any ideas what's going on? Or is it a case of sending it back & get a replacement?

Thanks
«1

Comments

  • VikramKVikramK Posts: 9,500 TomTom Moderator
    Hi @s4ppa

    Welcome to the community and sorry for my late reply here..

    I have forwarded the findings to the team, very few -but have received similar reports before.

    With regards to the orientation thing, I would suggest that you try this:

    via Settings > Appearance > Display > Orientation lock

    Regards
    Vikram :)
  • Ian MuratIan Murat Posts: 1 [Apprentice Traveler]
    i have exactly the same issue as noted S4ppa
  • Ivan HelovanitchIvan Helovanitch Posts: 1 [New Traveler]
    I also have a 550 which keeps crashing,shutting off, restarting and failing to return the bt headset to talk so I can talk to my pillion and also orientation issues.
    I really don't think that locking the orientation to stop the screen changing is the answer when the device is made to rotate for different views.
    That is like someone complaining about the colour keeps going off on their TV and they are told just change the settings to B&W and they won't have the problem anymore.
    It really comes down to Tomtom not caring about their products,now they have your money that's it.
  • VikramKVikramK Posts: 9,500 TomTom Moderator
    Hi Ivan

    Welcome to the community!

    Our product team is already aware about this issue. The plan is to get this fixed in the next application release but the dates are still not confirmed.

    In the mean while I would suggest that you this to the customer service so they start logging these reports.

    Apologies for the inconvenience caused.

    Regards
    Vikram
  • AymaraAymara Posts: 19 [Master Traveler]
    Welcome to the Beta Testers Club :smiling_imp:

    Same problem here, as it seems. I bought a brand new Rider 550 yesterday, updated and configured everything (except headset) and thought I first try everything in a car ... my wife was driving, so I could concentrate on the TomTom.

    On the first route everything worked like a charm. But after going shopping, Rider on standby, when I tried to set a route to our home town, the device suddenly started to nearly freeze ... it got extremely slow, then it rebooted on itself and then the screen, though switched on, stayed black.

    It took me around 15-20 minutes, until I was able to reboot the device by holding the power knob very long. After the restart, it switched back into the route navigation as if nothing had happened. Unbelievable ... it continued the navigation after this mess.

    Btw, I only used the internal battery for this test and held the device in my hands ... no mount or external power source involved. Oh, and orientation was not locked and changed smoothly on the first route, when I tested it.
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    I Personally never had this problem with my Rider 550.
    But some people do have the Black Screen Problem.

    Copying my settings to a Rider 550 with the Black Screen Problem made the device stable (up to now)

    You can try to enable Orientation lock and use 2D mode.

    I hope this also solves the problem for you.
  • AymaraAymara Posts: 19 [Master Traveler]
    RoadRider wrote:
    You can try to enable Orientation lock and use 2D mode.

    In my case orientation lock was the only setting needed to avoid the black screen issue.
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    In our case enable Orientation lock didn’t solve the Black Screen Problem.
    After enabling 2D mode the problem was solved.
  • AymaraAymara Posts: 19 [Master Traveler]
    RoadRider wrote:
    In our case enable Orientation lock didn’t solve the Black Screen Problem.
    After enabling 2D mode the problem was solved.

    Interesting ... so far I only read about orientation lock to be needed and in my case it worked.
  • HendrikPV40HendrikPV40 Posts: 3 [Apprentice Seeker]
    Hi guys
    I just bought the 550 and also have the black screen issue. It's a half year after the first mention of the problem...
    Shouldn't there be a firmware update by now to fix this?
    I don't have the freezing problem (yet) but I put the system in 2D from the beginning as I prefer this setting.
    As said by Ivan shutting of the rotation isn't a real solution.
    I'm close to sending the device back and reclaiming my old rider 400 which I now passed on to my girlfriend :-p
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    You can try driving without Bluetooth connection.

    And if this solved the problem add the connections one by one to find the misbehaving device.

    I still didn't have a back screen on my device. (unless I turn it off.)

    (I prefer 2D and have Orientation lock on. My connected phone is a Moto X4 and headset is a cheap A2DP device (connected to a FM transmitter) or directly to my Interphone tour )
  • footyfooty Posts: 3 [Neophyte Traveler]
    First ride out and experiencing the same issue.
  • KifferKiffer Posts: 1 [New Seeker]
    I too have the same problem, also I do not get riding instructions through the headset. All I get are the speed limit change beeps.
  • DGRDGR Posts: 4 [Apprentice Seeker]
    edited May 2019
    well I cant suss it I have tried both the methods above singly and together and to get it to power up I have to press the power button for a long time to power the unit up which is basically a reset. Currently not impressed and looks like Ill have to go back to my Garmin as its very frustrating waiting for the device to sync up with my drive every time I power it up.
  • DGRDGR Posts: 4 [Apprentice Seeker]
    OK after some fiddling about I have discovered that the screen doesn't return from sleep if the brightness is below 35%. The buttons can be pressed but are not visible so for example when it goes into night mode and its set to less than 35% brightness the screen doesn't wake up but I could press quick settings icon in the top left corner and then press the night mode toggle ( though not visible) and the screen came on at full brightness. I now have the night mode set to 35% and haven't had any issues YET.
  • barrysayerbarrysayer Posts: 2 [Apprentice Traveler]
    Mine is doing the same. I’m gobsmacked that the advice from TomTom is to put the lock on the device. A ‘premium’ satnav with a bloody premium price.
  • HendrikPV40HendrikPV40 Posts: 3 [Apprentice Seeker]
    @barrysayer I completely agree!

    @RoadRider
    RoadRider wrote: »
    ...
    And if this solved the problem add the connections one by one to find the misbehaving device.
    ...
    If all devices work perfectly and one gives freezing and black screen issues, I think that is the misbehaving device.

    TomTom can't expect everyone to buy different phones/headphones because their device gets confused...
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    When the connection with your Phone is the problem there are alternative connection methods that can solve your problem.

    When you use MyDrive for the Bluetooth connection with your phone the Rider uses a BT Low Energy connection. This was optional in BT4 and standard in BT 5.0 so this is still recent BT technology.

    Many older phones have bad BT LE implementations.
    Phones with a bad BT LE implementation also have issues with most activity tackers.
    When your phone is a Samsung and you upgraded to Android 9 you will have 90% change of getting BT issues because Samsung forgets to clear the hidden caches.

    When you have a phone with a bad BT LE implementation like a Huawei you can switch to the BT Tethering configuration like the older Rider 4x0 series.

    I also know people who switched to WiFi hotspot but this is not supported by TomTom.
    But this solved a lot af issues for them.

    (dit you already try the latest Firmware upgrade for your Rider?)
  • HendrikPV40HendrikPV40 Posts: 3 [Apprentice Seeker]
    RoadRider wrote: »
    ...
    When you have a phone with a bad BT LE implementation like a Huawei you can switch to the BT Tethering configuration like the older Rider 4x0 series.
    ...

    Now that's interesting! Any idea where I can find this setting?
    I'd love to get rid of the battery consuming MyDrive app.
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    Simple remove the MyDrive App.
    Than remove the BT connection to the Phone on your Rider and Remove the Rider BT connection on our phone.

    After this you can configure BT tethering.
    https://uk.support.tomtom.com/app/content/name/Connect/page/3

    (Sire and Google Now will not work this way. MyDrive is needed for this.)
  • KunotomKunotom Posts: 1 [New Traveler]
    I have a rider 450. It does all these things. Sudden reboot, black screen, sudden orientation change, all without apparent reason. Then it takes 20 minutes sitting by the roadside while the device crawls back to functioning order.

    I contacted tomtom support twice and they have not been able to fix the problem.

    Given the price, I am immensely annoyed, because I could have bought a cheap product instead, to have such problems and save a couple of hundred Euro.

    That something goes wrong is one thing. But this is a common and well known problem and tomtom are unable to sort it.

    Its my second device from tomtom and all I can say is: Never again.

    One very disappointed customer.
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    Best practice is to enable the orientation lock.

    A few weeks ago my Rider 550 had black screen and reboot problems.
    When I checked the Bluetooth settings the connection with my phone was restarting all the time.
    After rebooting my phone the problem was solved. Driven 1500 km after this whitout any problems.
  • dwangdwang Posts: 46 [Outstanding Wayfarer]
    edited September 2019
    I have same sort of problem.
    Screen goes black and after a short time it comes back.
    Its not a restart.

    I have a rider 450
  • RoadRiderRoadRider Posts: 455 [Supreme Pioneer]
    Did you enable orientation lock?

    Also try what happens without Bluetooth connections.
    Turn of your phone and headset. If this solves your problem try with only the phone or headset to find the misbehaving Bluetooth device.
  • RobsTVRobsTV Posts: 3 [Apprentice Seeker]
    Today I was preparing to send a new 550 back to Amazon for exchange due to screen going black, but came here for a quick check first. Exact same issue, still present in April 2020. Must lock rotation. I guess a real fix will not happen?
Sign In or Register to comment.

Who's Online in this Category0