Go520 won't update — TomTom Community

Go520 won't update

Bought a (new) Go520 about three weeks ago, just noticed the maps are out of date (05/2016). Tried to update using wifi and usb but the unit insists it is up to date. Oceania maps are v971. How do I get it to update? on my other, older one, the maps are v1045 (12/2019)

Answers

  • DougLapDougLap Posts: 5,623
    Superuser
    Hi @pedask

    Here are a few things to try .

    Is your GO520 logging into your account.

    Tap Menu
    Now Tap the word Menu Top Left to see which of the 4 options are connected.

    If it is not connected to My Drive then go to My Drive in Settings and Log in. Now check to see if Updates are available. May take a few minutes to say so.

    Go to Add a Map in Settings/Maps and find Venezuela and select and load that map on to your device. This has longterm benefits as by having this very small maps (circa 30mb) loaded on the internal memory means that should you have a problem during updating your main map and as a result lose it then this small map enables you to start the GO520 normally and easily resolve the problem .

    Having loaded the Venezuela map and checked it is okay, you can now go to Settings/Maps and delete the Oceania map on the device which the unit will not let you do at the moment. Having deleted the map turn the unit Off and On and now go to Add a Map and select the Oceania map and load it. This should give you the latest version of the map.

    Keep an eye out for announcements on here for when the next map updates are released and see if you are offered them. If not then contact Customer Support which you may have to do at the moment via Chat or Email rather than by Phone.

    Doug
  • pedaskpedask Posts: 6 [Apprentice Seeker]
    Thanks Doug but I forgot to add that the app version is still stuck on 16.401.0077.411 (09/2016). I tried your answer, it is connected to My Drive but when I hit menu, there is no menu name in the top left corner. If I try to add a map, nothing is available.
  • YamFazManYamFazMan Posts: 17,087
    Superusers
    edited April 4
    Hi
    @pedask
    Further to Doug's post....
    I've replied to your other Post....
    Here... https://discussions.tomtom.com/en/discussion/comment/1700261/#Comment_1700261

    ATB YFM
  • DougLapDougLap Posts: 5,623
    Superuser
    Hi @pedask

    Just to be clear I was not suggesting you Tapped Menu etc when the GO520 was connected to your PC. Just start the GO520 normally then Tap Menu and then you should see Menu top Left and the Wifi icon etc top Right.

    One thing is that if you get an Operating Software update you will have to do that first before any map updates etc.

    Doug
  • DougLapDougLap Posts: 5,623
    Superuser
    Hi @pedask

    Hopefully either @VikramK or @lampard can have a look at your account on The TT servers on Monday and make any changes they think are needed.

    Have a look back here to see if they have any advice.

    Doug
  • pedaskpedask Posts: 6 [Apprentice Seeker]
    Thanks Doug. I have tried both connected and unconnected, no difference, I don't get the top left Menu. I suspect it is a deeper technical problem
  • VikramKVikramK Posts: 9,886 Moderator
    Hi @pedask

    Could you send me the serial number of your TomTom through a private message, please?

    Regards
    Vikram
Sign In or Register to comment.

Who's Online in this Category0