New version of TomTom HOME released — TomTom Community

New version of TomTom HOME released

Hello All,

We have released a new version of TomTom HOME.

The update should cover fixes for the several ongoing issues related to TomTom HOME installation and update failures.

Versions are :

• Windows: (W10 64bit)
• MAC: (OS 10.12 till 10.15)

This release should fix the issues listed below-

# TomTom Home does not work on the latest iOS Catalina (10.15).

The new version should fix installation installations issues of TTHOME on MAC (starting from OS10.12 till 10.15). The TomTom Home installer has been modified and it will check automatically if any update from Java (JDK) is necessary or not. If necessary it should install the missing component on the background. (customers don't need to make the Java updates manually).

# TomTomHome offered as critical update fails to install

The TomTom HOME installer for Windows has been also modified and it will automatically install the Microsoft Visual Studio component (vcredistx64.exe).

# Mazda NB1 - USA Map installation downloads to PC but fails to install to SD - "This file is invalid (Archive file)

# TomTom HOME Unable to select map zone after update

# TomTom HOME hangs when "checking for updates

# TomTom HOME2.20.4.1267: after "update & install" page stuck on " Busy changing files"



  • SimonAlgeraSimonAlgera Posts: 2 [Apprentice Traveler]
    Thanks Vikram! Finally macOS Catalina support!
  • YamFazManYamFazMan Posts: 20,073
    edited January 2020
    Hi Vikram

    Thanks Win10 64bit installed without a hitch....

  • jim52jim52 Posts: 7 [Apprentice Traveler]
    edited January 2020
    continually crashes on startup Mac osx catalina - followed the directions to download TomTomHOME2maclatest.dmg - it installed and crashes - tried uninstalling and reinstalling numerous times
  • jim52jim52 Posts: 7 [Apprentice Traveler]
    any other suggestions?
  • LepreLepre Posts: 107 [Sovereign Trailblazer]
    I have also updated the latest version of TOMTOM HOME, but it keeps crashing. Windows 10 64 bit
  • VikramKVikramK Posts: 12,711 Moderator

    Thanks, I have added this to the ticket.


    Could you do a clean uninstall of the application? I would recommend that you try Revo-uninstaller.

    Once done, download a fresh copy of the application from here

  • jim52jim52 Posts: 7 [Apprentice Traveler]
    Thanks much
  • schmiegschmieg Posts: 7 [Apprentice Seeker]
    I want to enter this discussion as well. I have TomTom Home2 installed on my Win64 desktop machine and tonight I went to update the maps. As TomTom Home boots, it opens a window in the application saying it is downloading a critical update and that the window will close when the download is complete. According to the bar at the bottom of the application, the download quickly completes, but nothing further ever happens. I let it sit for several hours with no changes. I completely uninstalled TomTom Home, cleaned out all old files and the registry and tried it again with the same results. I then tried it on my Win64 laptop with the same results. The last update got things working after several months of being unable to download maps and now this happens. When will this be fixed?
  • YamFazManYamFazMan Posts: 20,073
    edited March 2020

    Here's a previous fix you may want to try....
    YamFazMan wrote: »
    I assume your device is one of the End of Life devices ???

    The first install of Home2 v2.11.9.702 is the current Home 2 for devices that are NOT END OF LIFE... If Home2 v2.11.9.702 senses that the connected device is END OF LIFE (Detected by Serial Number)... Then Home 2 recognises the device is EoL and offers the Mandatory update Home2 v2.20.4.1267....

    The Mandatory version of Home2 v2.20.4.1267, is a downgraded Home2 where only the Menus and Features that Tomtom allow for EoL devices are active... Menus like Maps or Live Services updates and some other features have been deactivated....

    Here are two Options you may want to try... I prefer Option (2)


    notboris wrote: »
    Right I have finally cracked it and I am running and able to access version

    I will now explain what I actually did, its easy really, you will kick yourselves. It is not the fix YamFazMan suggested but because of YamFazMan's input it led me to finding the fix, so big thanks for that YamFazMan.

    Right, after my two attempts to fix the problem as outlined in my 6.02pm post. I was at the point where I had installed on my PC TomTom version which if you attempted to run it, it insists you update to version but just aborts on a loop. Now that installed version was sporting the earlier doctored application.ini file to Version so that alteration to the application.ini file altered nothing.

    The above is just to show you how I got to where I am now.

    I had my TomTom in its updating cradle connected to the PC.
    I fired up TomTom Home clicked on the "critical update" link and as soon as I saw the file download had finished, I closed the program via "Task Manager"
    I then uninstalled TomTomHome version was no more.
    I opened the download folder and clicked on version

    And thats it, it installed and updated my satnav which is now sporting the latest "mapshares" and the latest "Quick GPfix" version. 1566978324

    Also see the below quote by BillB123...
    An alternate way to close "Critical update" link....
    BillB123 wrote: »
    I have this problem also trying to use Home for my GO 730, just gets stuck in a loop and won't update.
    I found a work around, Alt and F4 closes the update window and lets you continue.

    Option... (2)
    This works for me....
    I can install all of the updates that Tomtom allow for my EoL NAV2 Start device....
    Note... Using this option you will be running a modified version 2_9_91_411 that doesn't call for the latest problematic update to be installed

    YamFazMan wrote: »
    Modify Tomtom Home to use older version of tomtom Home... (Mabe usefull for End of Life TomtomDevices with No further map or other updates)

    (1)… Uninstall TomTom Home
    (2)… Download last "good" version 2_9_91_411 from....

    (3)… Install it without running....
    ie, un-check the 'Run Home' tick box when installation completes

    (4)... Using Windows Explorer, navigate to
    C:\Program Files\TomTom HOME 2\xul (32 bit Windows)
    C:\Program Files (x86)\TomTom HOME 2\xul (64 bit Windows)
    and find application.ini file
    (5)… Edit application.ini file (you might need admin privileges) and modify "Version=" to "Version="
    (6)… Run TomTom Home. It will believe to be running latest version and therefore not pull the update

  • schmiegschmieg Posts: 7 [Apprentice Seeker]
    This morning, I attempted it again around 11 am and it worked perfectly on my desktop and my laptop. I think it was a corruption in the update on the TomTom site that my machines were downloading.

    YamFazMan, I am not running one of the End of Life devices, but an NB1 system for my Mazda 2014 CX5. This was clearly a probleem on TomTom's part.
  • GrumbletweezerGrumbletweezer Posts: 20 [Apprentice Traveler]
    Not sure if this is linked, but I updated Home this morning then tried to up-date my map. It's about 10pm now and since 8am I get 'Our servers are very busy right now'. That's a long time for servers to be busy. I've used the try again button and restarted Home. Guess I'll just try again tomorrow.
  • Malletts1Malletts1 Posts: 3 [Apprentice Seeker]
    I had followed your advice in December 2019 to finally get TomTom Home to update to 64bit on my MAC. It now does not recognise the SD card from our Mazda CX5 - what is your suggestion now? Currently I hold a map update that I can't install - a lot of wasted expense at this time.
  • LepreLepre Posts: 107 [Sovereign Trailblazer]
    edited January 2020
    Today I uninstalled TomTom Home and reinstalled TomTomHOME2win.exe, but it keeps crashing. The program is not working properly. (New version After starting Home made a critical update
  • jim52jim52 Posts: 7 [Apprentice Traveler]
    knock knock...........
  • jim52jim52 Posts: 7 [Apprentice Traveler]
  • LepreLepre Posts: 107 [Sovereign Trailblazer]
    Windows 10 64bit
  • jim52jim52 Posts: 7 [Apprentice Traveler]
    any fix for the OS X operating system? - I am still waiting on being able to update
  • GeraldaoGeraldao Posts: 27 [Master Traveler]
    Hello , I have the same pb following the update of MAC OS CATALINA. I'm from France, and ask for help to the support and the user forum in last October.
    New version of tomtom HOME has solved nothing to the result of not being able to ope -n t-HOME application (a new error message occured about my disk unable to be writtable,... while it's correctly used by my tomtom live GPS), well, really anoying after 4 or 5 months after declaring the pb to the support office (in France I guess).
    if anyone have an easily way of getting out of this pb, please let me know :)

  • jim52jim52 Posts: 7 [Apprentice Traveler]
    are we to assume @VkramK that this is not going to be fixed at all for the Mac os catalina?
    it has been another month
  • LH-AdelaideLH-Adelaide Posts: 2 [Apprentice Traveler]
    I've tried updating my HOME to the new version, but all I get is an endless loop where I download the new version of HOME and then get told that I cannot use it.

    What can I do to get a fully functioning version of HOME working?
    Windows 10.

  • YamFazManYamFazMan Posts: 20,073

    Is there any way of adapting the Windows 10 Tomtom Home Fix... Option (1) in this post for your Mac ???

  • LH-AdelaideLH-Adelaide Posts: 2 [Apprentice Traveler]
    Thanks, @YamFazMan -- deleting and re-installing worked a treat. I'm now a happy bunny, many thanks!
  • YamFazManYamFazMan Posts: 20,073
    You're welcome, glad you're sorted :)

Sign In or Register to comment.

Who's Online in this Category0