TomTom not connecting to MyDrive Connect — TomTom Community

TomTom not connecting to MyDrive Connect

OnkaloOnkalo Posts: 6 [Master Traveler]
I recently used MyDrive Connect because I wanted to download some updates for my SMART 52. The first updated seemed to work fine, but there are several more available.

Now when I plug in my TomTom and start MyDrive Connect, MyDrive says the TomTom is connected, but the TomTom says "Please open or install MyDrive Connect on your Computer".

When I try to download updates, they download fine, but then the MyDrive screen gets stuck on 'checking'.


  • YamFazManYamFazMan Posts: 16,546 Superusers
    Welcome to the site....
    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here...

    Or... Instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...
    JimB0b wrote: »
    Thanks @YamFazMan
    I'm on a Mac but have found the two folders you mentioned (Home3 and MyDriveConnect) and deleted them. Hurrah.. that's done the trick after a couple of frustrating weeks I've updated it successfully.
    Many thanks for the advice.
    On a Mac....
    The "HOME3" and the "MyDrive Connect" folders are located here...
    MacOS: Users\Username\Library\Application Support\TomTom\

    "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"
  • OnkaloOnkalo Posts: 6 [Master Traveler]
    Hello, thanks for the welcome.
    I followed the instructions in the link exactly for uninstalling and reinstalling MyDrive Connect.
    When I plug my device in and sign into MyDrive Connect it detects the device, and tries to add it for a while. Then I get the message "We are sorry something has gone wrong. It is currently not possible to add your device to your account. Please try again." I click 'Try again", but the same thing happens.
    I have also tried deleting the folders you mentioned, turning off "USB Selective Suspend", and I have tried using other USB ports on the PC.
    Is there something else I can do please?
  • OnkaloOnkalo Posts: 6 [Master Traveler]
    If no-one knows the answer to my problem with MyDrive Connect, is there any other avenue I can pursue? Is there a way of getting in touch with the company?
  • dhndhn Posts: 33,288 Superusers

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • YamFazManYamFazMan Posts: 16,546 Superusers

    Have you tried a Soft/Drum roll restart on the device ??? This restarts the devices Operating System afresh


    Charge the device for at least 2Hrs "OR" have the device plugged into a power supply
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles....

  • OnkaloOnkalo Posts: 6 [Master Traveler]
    Thank you very much for the advice.
    • I tried restarting the TomTom but I still have the same issue.
    • I tried phoning the support line but the office is closed.
    • I have tried the 'contact' link on the support section of the website, but it does not lead anywhere.
    • I have tried using a different PC.
    Still the same problem: MyDrive Connect reacts when I plug my device into the computer, but it fails to add it.
    Any other suggestions?
  • LAURE123LAURE123 Posts: 1,521 Superuser
    edited March 23
    Hi all


    MyDrive Connect (MDC) should not ask you to add your device in your TomTom account if this has already been done in the past. Maybe unnecessary questions but I'm wondering ...

    - In your Start 52 you are well "Log in" with MyDrive and your TomTom account?
    (this is essential for your updates and services)
    To check, in your device ==> Main Menu (4Dots....) / TomTom Services / MyDrive ==> if there is no "Activated" ==> enter your email and password / "Log in".

    You use the same email and password in your device and to log into the MDC software on the PC? You have not recently deleted your Start52 from your TomTom customer account or changed your email or password or created a new TomTom account?

  • OnkaloOnkalo Posts: 6 [Master Traveler]
    OK I think I know what the problem was - my device is added now, and I think it's because I disconnected my VPN.

    I have to thank LAURE123 for that - I went to TomTom Services / MyDrive on my device as suggested and it said 'Not connected', leading me to think there was something about my internet connection it didn't like. I disconnected my Nord and successfully connected my device. But I'm not convinced my device is properly updated.

    TomTom Services / MyDrive still has a cross on it and now says 'Not logged in'. I put in my email and password and it says it can't connect to TomTom servers (this is with my VPN still switched off). Maybe a temporary problem? I'll keep trying.

    And while MyDrive Connect says that it's connected to my device and everything is up-to-date, my TomTom is still saying that my Speed Camera Updates are expired, even though MDC says it is successfully installed.

    Progress, but not quite there yet! Thanks for everyone's help, and I'll try again tomorrow.

    PS. I assume that MDC had to add my TomTom again because I uninstalled it and reinstalled it, as per YamFazMan's suggestion
  • OnkaloOnkalo Posts: 6 [Master Traveler]
    Tried again today, everything connected and updated fine. Must have been a temporary issue with the servers yesterday. All good! Thanks everyone! =)
  • YamFazManYamFazMan Posts: 16,546 Superusers
    You're welcome, glad you're sorted :)

  • LAURE123LAURE123 Posts: 1,521 Superuser
    Hi @Onkalo

    Glad for you that everything went well in the end for your updates and thanks for your feedback. :)

    VPNs and firewalls can block MDC, these are known issues. And not always easy to solve, each PC configuration being different. You have found your solution by yourself. =)

Sign In or Register to comment.

Who's Online in this Category0