TomTom Start 25 No GPS in new Mercedes Van — TomTom Community

TomTom Start 25 No GPS in new Mercedes Van

My Tomtom works perfectly in my car, and in our older Mercedes and Iveco vans - but when put in one of our 69 plate Mercedes it will not find a satellite.
I have left it connected, and searching, for several hours without success. I have also tried various positions in the cab.
Other drivers have reported the same issue with their Tomtoms.

Any ideas on what to try next? Joking apart, I'm lost without my Tomtom!

Best Answer

Answers

  • VikramKVikramK Posts: 10,606 Moderator
    Hi @Cruant

    Welcome to the community!

    Could you try the troubleshooting steps advised on this FAQ- https://uk.support.tomtom.com/app/answers/detail/a_id/16092

    Regards
    Vikram
  • CruantCruant Posts: 3 [Apprentice Traveler]
    Thank you both for replying, I appreciate your time.

    Vikram:
    I checked out that FAQ before posting, but I've just gone through it again to double-check. No help.
    The crucial point of the problem is that I CAN get a GPS lock If I use the device anywhere else, it's only while in the new Mercedes that it fails.

    Doug:
    That's an interesting question. I don't know, is the answer - but it would make sense if that is the case.
    How would I check or find out if it does have a metallic coating? And if it does, is there any way to still use the satnav beyond putting it on the outside of the cab?

    Thanks again,
    Keith
  • DougLapDougLap Posts: 6,672
    Superuser
    Hi @Cruant

    You could ask Mercedes. They may be able to suggest where you could fit the GPS if the screen has a metallic element. Sometimes those with heated front screens have issues but you can usually find somewhere where it is okay..

    Doug
  • CruantCruant Posts: 3 [Apprentice Traveler]
    Yeah, my car has a heated front screen, but the GPS works fine in there.

    I've had a look at the Mercedes website, and it seems that the Sprinter vans come with a wideband filter in the screen as standard - almost certainly what the problem is here, I would think.

    The most annoying part of this is: the handheld system supplied by my employer works fine in the van - when it works. We've been having problems with them lately, and I always carry my own as a back up. Until this problem started, I was using my own out of preference.

    I'll try something silly, and put the GPS at the extreme right of the windscreen, and open the drivers side window fully - see if the signal gets through that.
    Gonna be a while though, as I'm stuck at home for the next week and a half. Wonder if you can guess why. :/

    Thank you for the idea, that's almost certainly the cause of my issues, and I never thought of looking there.
  • DougLapDougLap Posts: 6,672
    Superuser
    Hi @Cruant

    Some older units could fit a GPS signal cable. I don’t k is if yours can Hopefully someone can advise if it is possible. On the Start 25 if that is the one you are referring too.

    Doug
Sign In or Register to comment.

Who's Online in this Category0