TomTom Home & MacOS X Catalina - Page 7 — TomTom Community

TomTom Home & MacOS X Catalina



  • Leonarda55Leonarda55 Posts: 0 [New Seeker]
    My MAC is updated to Catalina (64 bit.) At doesn't support anymore my Carmainat Live updates (32 bits)
  • pdaupdau Posts: 0 [New Seeker]
    I use macOS Catalina, and yesterday I downloaded the new version of TOMTOMHOME ( in 64 bits.
    But now I cannot update my cards (FRANCE and WesternEurope). The process never ends.
    So I deleted TOMTOMHOME and reinstalled again this new version (, but this time, the application closes itself after the first popup. So I cannot update myself cards.
    coud you help me please.
    thanks in advance.
  • norsemannorseman Posts: 2 [Apprentice Traveler]
    So...what's the latest to get this working on Catalina 10.15.3? This sure is taking a long time to resolve. :/
  • tgreenw900tgreenw900 Posts: 6 [Master Explorer]
    Still crashing every time I use it. The last rollover deal that kept the clock from working was enough to get me to think about switching brands. Now this is the last straw. I'm a gd motorcycle rider not a f***king software engineer. Enough already

    From the factory store 200 USD. Put a fork in me I'm done with Tomtom.
  • tgreenw900tgreenw900 Posts: 6 [Master Explorer]
    Finally was able to get the damn thing working. I had to manually find everything related to Tomtom in Applications and Library-support. Then hit "show contents" from there control click "move to trash" then hold option key and empty trash. It would then load with the latest Java updates. A few hours to figure it out. Now I find I have to pay for map updates.
  • tgreenw900tgreenw900 Posts: 6 [Master Explorer]
    So figure out that my 2013 Rider is no longer supported so after a long thought and a few beers I bought a Rider 550. All my problems stemmed from having an outdated unit. It's working on old maps. After a quick search on ADVrider the Garmins have equal or worse problems. Hope that Tomtom can keep updates and rollovers in check. Over all it's been a pretty good unit. Now off to read the owners manual for the Rider 550. Be safe out there.
  • tgreenw900tgreenw900 Posts: 6 [Master Explorer]
    Wish I could edit posts but now after buying a new Rider 550 off Amazon for a great price everything is working splendidly. I did not read the owners manual but just figured it out. The way it's supposed to be. I put in an address and it took me there and back. Easy screen to read and Tomtom Home is loading and working well.
  • kieronkieron Posts: 513
    Hi there tgreenw900 -

    That’s very good news indeed! The Rider 500 series are really well constructed devices and I’m extremely pleased as to how my R.500 has been so far.
    Many thanks for letting the forum know.
    Safe riding. :)
  • CherylKjCherylKj Posts: 0 [New Seeker]
    I have deleted the 32-bit version and downloaded the latest offered by TomTom, but TomTom Home quits before I can log in.
  • norsemannorseman Posts: 2 [Apprentice Traveler]
    Got it work finally work on Catalina 10.15.3 by deleting all TomTom related apps and files. Reboot, then download again to reinstall.
  • ProbosProbos Posts: 1 [New Traveler]
    norseman wrote: »
    Got it work finally work on Catalina 10.15.3 by deleting all TomTom related apps and files. Reboot, then download again to reinstall.

    I removed the old version, deleted the old folders (Backup, Download, FromDevice, Sharing), restarted the system and the application started. Now it is also working on my Mac OS Catalina 10.15.4 with the exception of the backup function that still does not work.

  • DrewNDrewN Posts: 2 [Apprentice Traveler]
    I did not update to OSX Catalina on my Macbook Pro as TT Home did not support 64bit OS for my Go930 satnav. But after reading the above it seems to have been sorted, so I updated my Macbook to Catalina 10.15.4 last night. I deleted the 32 bit version of TT Home and used the link from Norseman above to download the new TT Home version which all seemed to go OK.
    I then connecterd my Go930 and it opened on TT Home and I updated with a few updates and then disconnected from my laptop.
    However I now have a problem starting my Go930. It gets to the legal screen and won't go any further. I have tried restting to no avail.
    Does anyone have any suggestions on how to get the Go930 to work?
  • DrewNDrewN Posts: 2 [Apprentice Traveler]
    I have been playing with my Go and if you connect it to the laptop and reset the Go and then restart it will connect to TT Home and I can see all the files on the Go in Finder. Is there a file/files that need to be deleted /amended to get my unit to work?
  • jowett328_un42jowett328_un42 Posts: 1 [Apprentice Seeker]
    Carminat TomTom Live. iMac running MacOS Catalina Version 10.15.4 - TomTom HOME is operating. Update "My device" selected. Now I'm stuck with "Busy changing files. TomTom HOME is busy organising your files. One moment please..." This has been showing now for 40 minutes! I need an expert please.
  • EtonfieldsEtonfields Posts: 1 [New Traveler]

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

  • TheBucketTheBucket Posts: 4 [Neophyte Traveler]
    Thought I'd put in a bit of good news. I use MacBook Pro running Mojave (can't go to Catalina yet due to some other proprietary SW I use for work). It told me I had to downgrade my Java - I did - then it told me a second time I had to update my TTH - I did - and then it loaded new maps and updates to my Rider 2013 and all seems to be working fine. I too have been waiting for a couple of years for TTH to be 64bit compatible, and it seems to be working. Frankly, I was kind of shocked. Fingers crossed, all worked and I'm good to go...just in time for my first ride of the year in a couple of days. It's finally warm enough
  • VaincanineVaincanine Posts: 2 [New Traveler]
    Same problem here - May 2020 and still can't update Mydriveconnect as not compatible with OS Catalina! I think I'm going to use Google maps from now on.
  • VaincanineVaincanine Posts: 2 [New Traveler]
    Same here - May 2020 and cannot update TomTom as MydriveConnect still not compatible with OS Catalina. Will be using Google from now on.
  • Snowr0Snowr0 Posts: 0 [New Seeker]
    Not sure how or why, couldn't get my rider to sync with Mac, running Catalina 10.15.4, always been no problems.
    Reloaded TOMTOM home, latest version for MAC, 10.12 or newer, install appears all ok, but when opend it displays the Home desktop for about 1 second, then crashes! Tried several times and can't get it to work! Eventually regressed to old Windows laptop to ressurect the Rider! Any ideas?
  • meob63meob63 Posts: 1 [New Traveler]
    I still can't use TomTom on Mac. Now it is summer and I need it...
  • benimobenimo Posts: 3 [Novice Seeker]
    Hello !!!
    I use Tomtom Rider from 2013. I bought an European update from the tomtom website for 80 euros.
    In order to obtain this update I must download the TOMTOM home but unfortunately I cannot open this App. I receive an error message "The developer of this application must update for it to work with this version of macOS. Contact the developer for more information."

    My operating system is Mac Os Catalina version 10.15.1.

    I got in touch with Tomtom customer service by phone and no one can give me a clear answer to my problem.

    If ever someone has faced the same problem please let me know.
    Thank you!!

    Best regards,
  • DougLapDougLap Posts: 8,829
    Hi @benimo

    I have Catalina 10.15.5 and I have got TomTom HOME version 2.20 on my MacBook. and it opens telling me I have not got a unit connected which is correct

  • DouglasGunnDouglasGunn Posts: 1 [New Seeker]
    Where do I download the latest version of TomTom Home (I'm using macOS Catalina 10.15.5)?
  • bsmithbsmith Posts: 4 [Apprentice Traveler]
    Usual wont let me instal just states dont meet the requirements
  • rupertdrupertd Posts: 3 [Neophyte Traveler]

    I've been trying to update my carminat tomtom memory card with new maps for months. I only have the SD card with nothing to plug into the satnav itself.

    I've tried using the Tomtom home app for Mac, the one it came with says 'the developer of this app needs to update it to work' and the new version says 'installation cannot proceed, as not all requirements are met' - with no idea what these requirements are I've also tried Tomtom mydrive connect, but that is for USB devices only.

    Thanks in advance,
Sign In or Register to comment.

Who's Online in this Category0