GPX export via MyDrive website

DougNowell Registered Users Posts: 1
New Seeker
I like TomTom MyDrive but want to export a route I've planned to be able to load it onto my Garmin - I've a BMW Nav Vi but also a TomTom rider.

When you export the GPX file Basecamp doesn't recognise it and won't load the route! I've also tried My Route App and that works ok but it would be really helpful to be able to transfer directly! Any clues/ideas?

Best Answer


  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    I have the same problem when I download a route now.

    It seems ther is something wrong whit the MyDrive Export to GPX function now.

    This is wrong in the actual GPX file
    Normally a route point is rte... MyDrive now exports ns2:rte...
    Same for track point normal trkpt.... now ns2:trkpt...

    TomTom added ns2: an that is wrong
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    Hi @DougNowell

    To repair your .GPX file.

    Make a backup of the file.

    Open it with Notepad.
    Edit -> Replace (Ctrl H)
    At Find what fill in ns2:
    Leave Replace with empty

    Hit Replace All

    Save the file.

    For me this procedure works.
  • cajar
    cajar Registered Users Posts: 5
    Apprentice Seeker
    I own TomTom Rider 550.
    Everytime I ride, I record route, then I export route to GPX file.
    It used to work fine, but today I have a problem.
    First of all, exported file had size of 0 bytes (empty GPX file).
    Finally, after some tries, GPX files are not empty, but they did not contain time information - only GPS coordinates.
    It's weird, because same route exported one month ago contains time data, but exported today - does not contain time data.
    Please have a look, the same route, exported two times - on the left export from July 2020, contains date and time information, on the right export of the same route but done today, and there is no date and time info.

    I tried many SD cards, I restarted device - still the same problem. Can you please help?

  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    This is very strange. The last Firmware update is one year old. So nothing changed on the Rider side. Most of the times when there are problems with recorded tracks the cause is not stopping the recording and save it with a new name or a corrupted SD card. Formatting the SD Card om a PC solves this problem.

    It is normal that MyDrive removes Time data from uploaded .GPX files. Time information is not needed when jou drive a track. So if file 2 is from MyDrive this is normal.

    I think the easiest way to test is to factory reset your Rider (most data is normally in MyDrive so you only have to backup non MyDrive data and remember some settings)
    Format the SD card on a PC. (FAT32)
    Record a Track. Stop recording and give it a name.
    Check the GPX file