Tomtom won't start up after update - Page 2 — TomTom Discussions

Tomtom won't start up after update

2»

Comments

  • Ausworkshop
    Ausworkshop Registered Users Posts: 1
    New Seeker
    They are hopeless. I agree. So frustrating , I just gave up on mine, was driving through bushfire areas getting lost because I can no longer use a device I paid for and upgraded so I could update easier through wifi. Next time I drive past a fire I think I'll throw this brick out the window. Useless waste of time and money, the mistake of buying a Tom Tom could cost your life down here right now.
  • Johnst
    Johnst Registered Users Posts: 29
    Prominent Wayfarer
  • dislab
    dislab Registered Users Posts: 5
    Apprentice Traveler
    I have a TomTom 540TM XXL, which runs fine in the past many years. A few days ago I thought I would give it a last update to see if some address errors would get fixed. The TomTom Home said my device memory is too small to get a map update, but it did update some share fixes. But now the GPS touch screen is dead: it always stuck on "Legal Notice" and I can't click "I agree". How can I fix this?
  • dhn
    dhn Posts: 33,374
    Superuser
    Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.
  • dislab
    dislab Registered Users Posts: 5
    Apprentice Traveler
    I was able to fix my tomtom by following instructions at https://discussions.tomtom.com/en/discussion/1115289/touch-screen-not-working-after-update. Basically after my gps was able to connect the desktop, I restored the software from an earlier date using tomtom home.
  • Shashank
    Shashank Registered Users Posts: 0
    Apprentice Seeker
    edited June 2021
    I have a Tomtom start 25 ( serial no. Starts with BQ..) Display has suddenly stopped working and reset does not work. I have tried with a replacement display and battery apart from the normal checks for charger etc. but no success. When I hold the power button for few seconds it makes a drum roll sound but then the screen remains black. Any suggestions welcome. Thanks