constantly get servers busy try again --JAN 2020

LPterc Registered Users Posts: 2
Apprentice Traveler
Not sure what is going on... but it would be nice to get some other response than "Our servers are very busy"
They have been busy for a MONTH. TomTom updates have always been SLOW - no matter what connection I try. Currently using 25MBS connection, hard wired system, re-installed MyDrive, deleted Cache (several times), manually removed the data apps program directory. I've spent the last 25 years fixing computers so I would term myself 'knowledgeable'. This is not even close to acceptable, and certainly doesn't present itself as a reliable device/company. I've used TomTom devices for over 10 years.
Via 1605 + 8GB memory card


  • JamesS241
    JamesS241 Registered Users Posts: 4
    Apprentice Traveler
    I've been trying periodically to update my Start 25 and Start 42 since last summer. I too get only the "Servers are Busy" signal. I've uninstalled the program etc. as suggested in other posts and nothing has helped. Will there ever be a server that can handle the load? I've tried clicking the Canada link and the screen changes to French! I've tried to call the Canada contact number and only get a "circuits are busy" signal. I've had several TomToms over the past 10 years and never had these issues til last summer. Is it being fixed?
  • dhn
    dhn Posts: 33,385
    Try completely removing MyDriveConnect using the FREEWARE version of Revo Uninstaller. Get it here:

    Then get a fresh copy at Install WITHOUT the device connected to the computer. Connect the device and see if you can update now.

    Phone support:
    1 877-757-7137
    Monday - Friday: 9:00 a.m. to 6:00 p.m. EST
  • LPterc
    LPterc Registered Users Posts: 2
    Apprentice Traveler
    edited February 2020
    thanks for the reply.... no difference. The issue seems to come from the server side with the horribly lagging response. The cache status.xml file reads:

    <urls cacheSuspended="false" cacheSuspendedType="PND">
    <url index="1" href="; percentage="100" contentLength="71813" cacheLength="71813" statusCode="200" timestamp="1580673803" validationMandatory="false" downloadSuspended="false">
    <md5 percentage="100" contentLength="32" cacheLength="32" statusCode="200" md5checked="true" computedMd5Hex="886653c70e8b8678adcec291b9939120"/>
    <muid type="ODS">WNxxxxGxxx49</muid>

    the cache show a content1 file of 71KB but NO update occurs and the program just spits out the "we are too busy thing"

    Mod edit: Please don't post private or personal information on a public forum. Thanks!
  • ArtRoc42
    ArtRoc42 Registered Users Posts: 2
    Apprentice Seeker
    Had that for days on my desktop. Updated straight away on my laptop. Both on wireless broadband at home.
  • YamFazMan
    YamFazMan Posts: 21,015
    edited March 2020

    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller then Reinstall MyDrive Connect....
    Using the Method Here...

    Or instead of UN-installing & RE-installing MyDrive Connect
    I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program just as effective for giving MyDrive Connect a CPR...

  • Vexed
    Vexed Registered Users Posts: 2
    Apprentice Traveler
    Thanks to YamFazMan followed your advice to the letter and now running on latest maps after days of frustration. Wished I'd looked on the community earlier
  • YamFazMan
    YamFazMan Posts: 21,015

    You're welcome, glad you're sorted :)

  • Ola_Olsson1
    Ola_Olsson1 Registered Users Posts: 2
    New Seeker
    Bad behavior by TOMTOM. Fix your servers, we have payed for this service.
  • DougLap
    DougLap Posts: 9,959
    Hi @Ola_Olsson1

    So have you tried the solution recommended by @YamFazMan in the post above which has been acknowledged as working.

  • YamFazMan
    YamFazMan Posts: 21,015

    See my reply to your 2nd post....