Tomtom 410 Rider - Stuck in Update Loop

AndrewFo Registered Users Posts: 6
Master Traveler
After the server problem yesterday where my device was constantly waiting for device to update. Today the update starts but loops continuously. It gets to 100%, then says "finishing up" then re-starts the update. Has done this for over 2 hours. Had to disrupt the update by crashing out of the update. Fortunetly this has not bricked my device. Any idea what may be happening? Thanks.


  • VikramK
    VikramK Administrators Posts: 14,066
    Hi @AndrewFo

    When I review the logs for the downloads on your device, I find pending download for speed cameras updates.

    Could you try few steps as below:-

    1. Disconnect the device and do a soft reset
    2. Clear the cache in MyDrive Connect-
    3. Connect the device again and check for updates.
    When updates are offered please don't click on update all.
    Using the My Content tab check which updates are getting offered.

    Select one at a time and click on update selected.

  • AndrewFo
    AndrewFo Registered Users Posts: 6
    Master Traveler
    Hi Vikram, I completed your instructions above exactly. Once again the camera update just goes into a loop. It gets to "finishing up" then restarts the update continuoulsy. I then selected the MAP update only, this gets as far as "checking" then does not progress any further than this. This is becoming really annoying - a £400 satnav which cannot be updated. I'm glad to say I am reasoably software / pc savy, if this was happening to a person with no technical knowledge it would be extremly difficult. Very poor show by Tomtom.
  • AndrewFo
    AndrewFo Registered Users Posts: 6
    Master Traveler
    edited February 2020
    Update, I contacted customer support who told me to do a soft reset and leave the device connected to my PC. The problem is, as soon as MDC detects my device is goes automatically straight to the update and try's to finish the update. I left the device loop for over six hours, still no luck. I have uninstalled the software, re-installed the software, deletd cache, numerous hard resets, soft resets etc etc and still no joy. I have wasted hours trying to resolve this issue. All this happened after the server issue. It must have corrupted the software in my device. I will insist Tomtom repair my device free of charge at their repair centre.
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    I had the same problem once with my old Rider 410.
    Solved it with Recovery mode using MyDrive Connect.

  • alvia135
    alvia135 Registered Users Posts: 2
    New Traveler
    I am currently having the looping update problem. Got some instructions from Support that did not work. Tried using Revo uninstaller to remove Mydrive Connect plus a few other steps. Finally tried the recovery mode option mentioned in this thread. It still just goes automatically into update, finishes and starts update again. I am at a complete loss trying to sort this. This may push me into buying a Garmin instead like many of my friends have already done. Tired and dissatisfied Customer!!