TomTom Home & MacOS X Catalina - Page 6 — TomTom Community

TomTom Home & MacOS X Catalina



  • FredottoFredotto Posts: 4 [Master Traveler]
    Finally seems to work again...
  • PcuboPcubo Posts: 2 [Apprentice Traveler]
    edited January 2020
    After having installed it correctly the application opens but then closes suddenly .. same errors as before ... can someone help me ? Catalina 10.15.2

  • TappendaaliTappendaali Posts: 8 [Apprentice Traveler]
    I have same problen than Pcubo. High Sierra v. 10.13.6. TT Home started, but closes iimmediately. Last version of TT Home and Java are intalled correctly. No error messages.
  • PaulHolmstromPaulHolmstrom Posts: 3 [Apprentice Traveler]
    edited January 2020
    I have updated to the latest version. It opens, but crashes immediately. I am still running Mojave (10.14.6)
  • troedtroed Posts: 5 [Master Traveler]

    Dear TomTom,

    This is not how you do software development in Java. Not only do you not require the removal of OpenJDK - I also have a newer version of Oracle Java 8 installed than the "minimum" version you require.

    /Vice President of Software Engineering, global company
  • macboymacboy Posts: 10 [Master Explorer]
    OK, so now I can finally load and open HOME on my iMac with Catalina. It also sees my XL 340S. The problem is it wants to delete my current map and voice because it thinks there isn't enough room for the current/updated map. I am trying to update my US region map. My TomTom originally had maps of Canada, Mexico and the US. When that became too big, I was allowed to download the US only map and that worded fine. Home always just automatically replaced the old map with the new one. I'm afraid to proceed since it now seems to want to "delete" my old map and I don't know if it will install the new one after that. Any suggestions?
  • troedtroed Posts: 5 [Master Traveler]
    edited January 2020

    For those who understand the below, this solves the issue if you already have a valid Oracle JDK 8 installed but the installer claims to need to install an older version and remove all your Java installations:
    $ pkgutil --expand TomTomHOME.mpkg /tmp/TomTomHOME
    $ cd /tmp/TomTomHOME/Scripts
    $ nano

    Find the following code (some way down) and comment out some of the lines, as follows:
    #        if [[ "${jdk_ver}" =~ 1\.8\.0_1[5-9]* ]]; then
                echo ${jdk_ver}
    #        else
    #            JDKREMVER[$i]="$jdkType $jdk_ver\n"
    #            JDKREMPATH[$i]=$jdk_path
    #            echo "Detected JDK: $java_ver"
    #            i=`expr $i + 1`
    #        fi

    Save the file.
    $ pkgutil --flatten TomTomHOME/ ~/Downloads/TomTomHOME.mpkg

    Double click the new mpkg in your Downloads folder.
  • troedtroed Posts: 5 [Master Traveler]
    For the "I have installed the app but it's just closes down when I try to open it" problem, if it's due to having another default Java installation than Oracle JDK, you need to do the following:
    $ cd /Applications/
    $ /usr/libexec/java_home -V

    Copy the path for Java SE 8 (/Library/Java/JavaVirtualMachines/jdk1.8.0_202.jdk/Contents/Home in my case)
    $ sudo nano startup

    Edit the JAVA line to use the path from above, with /bin/java tacked on at the end. Looks like this:

    Save and quit, now you should be able to run the application.

  • PcuboPcubo Posts: 2 [Apprentice Traveler]
    edited January 2020
    ok now application runs .... but Carminat on my Renault Megane show again " Impossible to find map " ... with software I have updated only QuickFix GPS...Can Someone help me ?
  • Jose_L_1957Jose_L_1957 Posts: 2 [Apprentice Traveler]
    edited January 2020
    The new version of TT Home (, seems to work well even with the latest version of Java (, but when you try to back up, the application unexpectedly closes and an error window appears.
    I reported this in a previous post with the Java version (, the issue has not been fixed.
    Any suggests?
  • OzReneOzRene Posts: 7 [Master Explorer]
    I have finally been able to update maps using Tom Tom. (been asking for around 6 months ie prior to Catalina release and had to suffer Tom Tom assurance it would be ok by October then their insistence that the problem was my computer)

    Had to use the Update functionality multiple times to get all the updates applied. The last two runs of which installed country maps. When completed it finally said no updates were available.

    WRT backup. This continually aborts (crashes). Help desk told me to read instructions on how to update my device....has absolutely nothing to do with software issue.
    Good to see I’m not the only one with this problem so hopefully they can fix this soon.
  • TappendaaliTappendaali Posts: 8 [Apprentice Traveler]
    troed wrote: »
    For the "I have installed the app but it's just closes down when I try to open it" problem, if it's due to having another default Java installation than Oracle JDK, you need to do the following:
    $ cd /Applications/
    $ /usr/libexec/java_home -V

    Copy the path for Java SE 8 (/Library/Java/JavaVirtualMachines/jdk1.8.0_202.jdk/Contents/Home in my case)
    $ sudo nano startup

    Edit the JAVA line to use the path from above, with /bin/java tacked on at the end. Looks like this:

    Save and quit, now you should be able to run the application.

    This don't work with my HighSierra v. 10.13.6. TT Home started, but closed immediately. In JavaVirtualMachines folder I have jdk1.8.0_152.jdk and jdk1.8.0_202.jdk.

  • VikramKVikramK Posts: 12,727 Moderator
    edited January 2020
    Hello All,

    For the problem where TomTom HOME opens and crashes with an error I will require three files as described below:

    1. HomeClientUpgrade.log

    2. H2CUServiceLog.txt

    Can be found here- Users/Username/TomTomUpgrade/logs/HomeClientUpgrade.log
    You can find users by holding down the ALT key> select Library from GO> from here you will see the user profile).

    3. MAC crash reports
    The crash report is in /Library/Logs/DiagnosticReports/

    Please send me the files through a private message so I can forward them to our development team?

  • KMCKKMCK Posts: 7 [Master Traveler]
    Amazing! It actually worked this time after over 3 months of strife!!
    The update did require deletion of the previous map as there was insufficient space, and there was one issue during the subsequent loading of the updated map that "froze" the update, however on a second attempt, everything ran smoothly and now seems to be up to date.
  • TomminTommin Posts: 1 [New Traveler]
    After updating it opens and closes immediately.
  • Andy1950Andy1950 Posts: 4 [Master Traveler]
    After getting 10 or more emails from Tomtom they told me on the last one that the Tomtom Home update would work,well
    i have tried it several times and it downloads ok but as soon as i open it crashes in a couple of seconds..They told me to try it after 1pm today. I WONDER WHY.
    I am not a computor tech so i have to take it to a expert to do it and its costing me loads of money.
    Has anyone been able to get the Home page to load and open
  • David LosadaDavid Losada Posts: 12 [Apprentice Traveler]
    On Mojave 10.14.6

    "Following unsupported version(s) of JDK has(have) to be removed from your computer inorder to install and run the TomTomHOME application.

    Installed JDK(s):
    JDK 1.8.0_241

    This process will remove the mentioned JDKs and install/re-configure the minimum required version of JDK (jdk1.8.0_152) to complete the setup.

    Would you like to proceed?"

    No. i don't want to proceed and remove the newest jdk wit a very old and insecure one. i simply don't understand why TT is developing software like that. In any case, from now on it's totally unnecessary for me to read any email with offers to renew my device. I've lost any confidence in TomTom.
  • BillyT54BillyT54 Posts: 0 [Apprentice Seeker]
    I have uninstalled the software and reinstalled it but there is no change. I use a mac.
  • Prof_ThunderProf_Thunder Posts: 1 [New Traveler]
    Having used a TT rider for several years, I have always been appalled by how a company can sell such devices and not develop decent software - the two go hand in hand. I'm actually amazed TT have survived so long. I recently connected my device and it said I had to download the new version of TTH. So I did. It then opened OK, downloaded the new maps to my device and then said error. After that my GPS says it has no maps on it any more and now when I try and install and run these updates the TTH just opens and immediately crashes, like others experienced. So I now have a GPS device I can't use. Thanks so much TomTom.

    Having just read through the 6 pages of this thread (yes, its really 6 pages!!!), we can obviously conclude the following:

    1. TomTom don't care about Mac users at all.
    2. Their software development team seem to be clueless and most of the suggested fixes come from their clients - just incredible! I could understand it if we as a community were trying to get "open source" software running but not to help out a bunch of amateurs selling expensive high tech devices.
    3. Given the price of their devices, TomTom should be developing top notch software, which they are obviously incapable of doing.

    Answer (for bikers who are not forced to use TT in their cars):
    TomTom please take note of this quick and effective fix to the problem in 3 easier steps than getting TTH to run on a mac. It's a useful one to pass on to the clients, and it will effectively allow you to reduce the workload of your software engineers.

    1. Throw the TomTom device in the trash and uninstall TTH from your applications folder.

    2. Go and buy a device from a serious GPS manufacturer who offer better support or just use your smart phone like many people do these days - I just opted for my smart phone with google maps in the end. It was easier than TTH and TT rider.

    3. Enjoy

    p.s. google maps are likely to be updated for life for free and actually work
  • Bert1959Bert1959 Posts: 9 [Master Traveler]
    Lots of happy customers... 🤣🤣🤣

  • claudiomezzclaudiomezz Posts: 1 [New Traveler]
    February 2020, still no update for the TomTom Home app ??!!
  • Xavier35Xavier35 Posts: 1 [New Traveler]
    This wouldn't have happened with proper "swift" programming...

    Until this horrible (java) App has been properly debugged, does anybody know where I can find the latest 32 bit version to install on an older Mac ?
  • DM_EssonneDM_Essonne Posts: 5 [Master Explorer]
    It's now impossible to use older versions of TomTom Home : after launch, an upgrade is automatically made. I tried to keep an old version for use on Mojave via Parallels, but it don't works. Now, TTHome works on Mojave, but crash after trying to backup on the computer. Perhaps better on Catalina now ?
  • ProsperotProsperot Posts: 6 [Apprentice Traveler]
    This is unbelievable, on the main download page you still only offer the 32 bit version... which doesn't work anymore...
  • madaxemarekmadaxemarek Posts: 1 [New Traveler]
    I cannot update my device as I cannot make my drive connect work. I get a window asking to enter the keychain password but does not accept it, then I cannot close the window it hangs in front of every other page blocking the view and I have to hold the off button on my iMac to turn it off and then restart and repeatedly force the app to quit which it says is not responding !
Sign In or Register to comment.

Who's Online in this Category1