tomtom go 50 continuously losing connection to pc

matys Registered Users Posts: 3
New Seeker

i ran into an issue while updating my tomtom go 50. I had just installed the latest Mydrive connect and updated the software, but when it tries to update the maps the device loses connection after 10 seconds and my pc tells me to reconnect it. The gps itself doesn't give any clues to being disconnected (power plugged in/screen says to not disconnect and use mydrive) Anyone an idea what is happeing? my GPS is now turned useless as there are no more maps on it and i have no other way of uploading maps to it.

original tomtom usb cable plugged directly into power usb port. As said, the os update went fine but the maps don't.

thanks for your feedback


  • DougLap
    DougLap Posts: 9,954
    edited January 2020
    Hi @matys

    If your GO50 is saying No Maps Found then here is a video to assist.

    Also do a Soft Reset on your device after the above . IE With the unit on and working Hold the ON/OFF button down for 20 seconds plus until you hear the drumroll sound.

    If the PC is s saying the GO50 is disconnecting then have a look at the USB power settings on your PC as they may be set to Turn Off to help with battery life. If you need any more advice on how to do this put USB Power Settings in Search above .

  • matys
    matys Registered Users Posts: 3
    New Seeker
    Hi Doug,

    thanks for your suggestion but it's no good for my problem. My tomtom never succeeds in downloading the files from the mydrive connect because it loses connection. In the meanwhile i tried changing the powerUSB settings and reïnstalling mydriveconnect / resetting the GPS but no luck. After 10 seconds of succesful connection it always disconnects. I have no additional antivirus/blocking software on my system.

  • Lochfrass
    Lochfrass Posts: 18,047
    edited January 2020
    Wich PC System do you have?
    Laptop or Tower PC? Windows or ios)
  • matys
    matys Registered Users Posts: 3
    New Seeker
    Lenovo thinkpad X1 with windows. The issue has to be there somehow because i just installed mudrive connect on an old acer laptop and although it took 11 hours it managed to get the map update loaded. my problem's solved
  • YamFazMan
    YamFazMan Posts: 20,998
    edited January 2020

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See...

    Win10 See…
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu... You will need to edit the Registry before the USB Selective Suspend menu will display (See Note... (4) below)

    Laptop users also see Note (1) (2) & (3)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu

    kt9idp9azgzl.jpgNote...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    Note... (3) Thanks User 333... Just had a similar problem with new Dell XPS 13 7390 (running Windows 10) which only comes with USB-C port. Found that I was able to update my TomTom Via 225 (using a supplied USB-C to USB-3 cable/hub) only after changing this setting in Windows 10:
    Settings - Device - USB - Un-tick this box: Stop devices when my screen is off to help save battery. If you're having problems with connected devices, clear the check-box.

    Note... (4) Editing the Registry...