MyDrive Connect misidentifies my VIA 1530 as a "VIA 125" and tells me that it will NOT update maps — TomTom Community

MyDrive Connect misidentifies my VIA 1530 as a "VIA 125" and tells me that it will NOT update maps

MyConnect Drive software version is 4.2.5.3734 and is configured to use the USA location.
I am based in USA.
I am sure that I have a VIA 1530TM because I still have the original box and the serial number on the box exterior matches the serial number on my device.
MyConnect tells me that I will no longer be getting any Map updates.
My VIA 1530TM came with Lifetime Traffic and Maps.
How can I get MyConnect driver to properly identify my VIA 1530TM??
Thanks

Comments

  • YamFazManYamFazMan Posts: 16,127 Superusers
    edited March 2019
    Hi
    @geisendr

    The same Tomtom Devices have different Names & Model numbers in different World Trading zones

    Try....
    With MyDrive Connect running...
    Tap on the Gear Icon screen top right
    Tap on the General Tab
    On the Country Tab... Select 'United States (English)'
    Save setting... All should be well :)

    mem19vyyk5cu.png
    ATB YFM
  • Lel0763Lel0763 Posts: 1 [New Seeker]
    I have the same problem, but My TomTom already has the Country correct. I even changed it to United Kingdom and changed it back to United States, but the problem remains. Any other ideas?
  • DennjDennj Posts: 2 [Apprentice Traveler]
    Same here. I have a VIA 1410 / 1415 and MyDrive Connect says I have a Start20 I didn't notice at first and it updated and corrupted everything. I can't get it to identify my device, so I can't download new maps to fix it.
  • dhndhn Posts: 33,278 Superusers
    The same model is known by different names in various regions around the world. That shouldn't affect your ability to download appropriate maps, etc.

    Support:

    877-757-7137
    Monday - Friday: 9:30 a.m. to 6:00 p.m. EST
  • DennjDennj Posts: 2 [Apprentice Traveler]
    Okay, I deleted "corrupted map" and the device downloaded a new one under the model name Start20 ...had to do a soft-reset a couple of times. Works now. Thanks dhn
  • GPSUserNowGPSUserNow Posts: 4 [Apprentice Seeker]
    I have this very same problem. My VIA 1530 came with Lifetime Maps. I updated just fine in August 2019, today November 15, 2019, I am unable to update the map. Getting Servers very busy message.
  • dhndhn Posts: 33,278 Superusers
    There isn't a Nov map release yet.
  • Synch24Synch24 Posts: 1 [New Traveler]
    So my VIA1530 was identified by the app as a VIA125 and was not updating. I called the support number posted above and spoke to a polite and professional tech who walked me through all of the steps (changing the settings under the gear icon, multiple physical device disconnects, closing and reopening the app, logging off/on the app and more) to finally (about an hour) get my device updating. I know now that there is not enough built in memory in the VIA1530 to hold the complete (lifetime) USA/Canada maps. A user needs to install an external 8GB SDHC memory card in order to install the full map. Stock memory requires making a choice of a geographical subset to download.
  • dhndhn Posts: 33,278 Superusers
    May I suggest you get a 16 gb card (or 32) from a reliable company such as SanDisk or Samsung. Don't rely on the internet auction sites as many cards sold there are frauds.
Sign In or Register to comment.

Who's Online in this Category0