Need help please........... — TomTom Community

Need help please...........

I have a new Via 1525 I just purchased. I got it mainly to monitor traffic as I do deliveries in the Boston area all day. I connected it to the computer and did the MyDrive connect thing and everything seemed to go ok. While it is connected to the computer the unit says Network status-Connected and shows the MyDrive is activated. Problem is as soon as I disconnect it from the computer to use it in a vehicle the Network status becomes Not connected and the MyDrive is unactivated and I cannot monitor Traffic. It is supposed to have Lifetime Traffic but I need the Network status and MyDrive to be connected/activated for that when it is in the vehicle.

Am I missing something? I've been trying all week to get the traffic working on this thing!

Any help would be greatly appreciated.

Thanks Rick
Tagged:

Answers

  • pelham89pelham89 Posts: 17 [Outstanding Explorer]
    Not sure if the traffic is linked with the problem, but you may need to sign into My drive in the Tomtom Services on the device
    Menu / Settings / My Drive. or Services? Not sure lf of which you have on yours.
  • DougLapDougLap Posts: 3,957 Superuser
    edited January 10
    Hi @PITBULL11

    If @pelham89 's suggestion does not resolve it then contact Customer Support and sort out your account with them. Do not answer the questions but wait for an agent to answer.

    United States
    877-757-7137
    Monday - Friday: 9:30 a.m. to 6:00 p.m. EST

    Doug
  • VikramKVikramK Posts: 8,782 TomTom Moderator
    Hi @PITBULL11

    Welcome to the community!

    The connectivity to get LIVE traffic information on VIA 1525 you need to connect it to an RDS-TMC supplied with the device.

    Regards
    Vikram :)
  • YamFazManYamFazMan Posts: 15,790 Superusers
    edited January 10
    Hi
    @PITBULL11

    Are you using the supplied RDS-TMC lead and is the device tuned into an FM (RDS-TMC) Broadcasting Station....

    ATB YFM
  • PITBULL11PITBULL11 Posts: 2 [Apprentice Seeker]
    Found out on another forum that I'm suppose to pair the device with a phone to get the correct signal for traffic. I didn't know this. Will try that out and report back here how it goes.

    Thanks for all your help, Rick
Sign In or Register to comment.

Who's Online in this Category0