MyDrive Connect "server busy, try again" — TomTom Community

MyDrive Connect "server busy, try again"

GarfyGarfy Posts: 3 [Apprentice Traveler]
edited November 2019 in MyDrive Connect
Why is it that almost every time I try to update my device, it always says "server busy, try again"? I used to update my Via 1515 with no problems with the earlier version of MyDrive Connect, but ever since this version was released, I often get the "server busy" error. I can't imagine that many users are updating because I've tried at different times during the day and evening. Note that when it's 11pm here, it's 1am PST. Thanks for any ideas.

Comments

  • YamFazManYamFazMan Posts: 16,742 [Elite Vanguard]
    edited February 14
    Hi
    @Garfy

    On the rare occasions I have a problem with myDrive Connect
    I Delete MyDrive Connect using the free version of Revo Uninstaller
    If you're using a Windows PC... Delete MyDrive Connect using the free version of Revo Uninstaller
    If you're using a Mac... Surely there must be a Deep Clean Un-installer Program available for a Mac ???
    Download & install the free version of Revo Uninstaller
    Here...https://www.revouninstaller.com/revo_uninstaller_free_download.html

    The main advantage of using the Revo Un-installer is that Revo first un-installs the Program using the Windows default un-installer ... Then scans and removes any of the left over files from MyDrive Connect that the default Windows un-install leaves behind....

    Video using the Revo Uninstaller
    The Free & Pro Versions use the same process....

    (1)... Uninstall MyDrive Connect Using the Revo Uninstaller
    (2)... Clear your browsers cache (Optional, but I find it helps)
    (3)... Restart your PC (Not Turn Off & Turn On again)
    Important... For bullet-point (4)
    DO NOT
    have your device connected to your PC)

    (4)... Reinstall MyDrive Connnect
    (5)... Connect & Turn on your device... Login to MyDrive Connect

    ATB YFM
  • KwirkeeBirdsKwirkeeBirds Posts: 6 [Master Explorer]
    Thanks for your help, that worked for me and I have updated all my maps. =)
  • TomFromMurrietaTomFromMurrieta Posts: 0 [New Seeker]
    Tried shutting down, restart/Boot. Reinstalled My Drive, but still getting Our Servers Are Very Busy...I've also done the try again, and everything else it tells you to do.
  • lampardlampard Posts: 4,637 TomTom Moderator
    Hi @TomFromMurrieta

    I assume you were trying to update the device (ends with serial # 2611) when you got the server error message. I've made some changes in the backend, can you please go through the steps here and resume the download of QuickGPSfix?

    Regards, lampard
  • IvooIvoo Posts: 3 [Apprentice Seeker]
    edited March 27
    They've been able to load the new maps. The reason why it couldn't be removed from the computer was because it really takes a long time to do the check, so it's active and can't be stopped in any way. JIf that the control somehow stuck and it went still so only help tritol cube and then garbage. Already all those Dryvery blah blah deleted from the PC and I do not want anything to do with it for a long time. Otherwise, thanks for your help and advice.


    Mod edit: Machine translated(Czech)
  • IvooIvoo Posts: 3 [Apprentice Seeker]
    edited March 27
    Oh my god what translation is here-half of what is in my previous post is garbled. Terror


    Mod edit: Machine translated(Czech)
Sign In or Register to comment.

Who's Online in this Category0