Go500 keeps restoring after update — TomTom Community

Go500 keeps restoring after update

I updated the maps on my Go500 about a month ago, and all seemed to be OK. Just over 2 weeks ago, I wanted to use it to navigate from Newbury to Liverpool, but when I connected it to a power supply (the USB charger which I use for my mobile phone) it started up (drum sound), but when the progress bar at the bottom of the screen got to half way across, it stalled. After a further delay, the "wait" circle in the middle of the screen came up for about half a minute, then the icons indicating that it wanted to be connected to a computer, but wasn't. We didn't have time to do any more debugging, so I left it until after we returned from our holiday.

I tried connecting the device to a PC (Windows 10, with TomTom Mydrive connect), and after restarting, Mydrive reported that the device was restoring. The progress count reached 100%, then reverted to 0% and started restoring again. MyDrive reported that it was trying to connect to the TomTom, but never got there. The device is now well out of warranty - is there any hope of resuscitating it?


  • RoadRiderRoadRider Posts: 714 [Revered Pioneer]
    Check the power settings on your PC.

    After disabling the power settings perform a recovery.

  • YamFazManYamFazMan Posts: 19,625
    edited October 2019

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work
    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu
    You will need to edit the Registry for the USB Selective Suspend menu to show

    Laptop users also see Note (1) & (2)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu
    Note...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    See... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855

    Important also see....
    NAV4 Memory Size v Map Size Catch22....
    See... https://discussions.tomtom.com/en/discussion/comment/1670583/#Comment_1670583

  • RainKapRainKap Posts: 7 [Apprentice Traveler]
    OK, how sad is this - I'm answering my own post!

    I started by removing the SD card and doing a hard reset - the device then booted up properly, though it complained that there were no maps (naturally enough, because the Europe map was on the SD card that I'd removed...). I overcame this by connecting to my computer and installing the Algeria map (chosen because it's near the beginning of the alphabet and a smallish download!). I formatted the SD card that I'd removed, using my computer, then put it into the TomTom and formatted it there - that seemed to work. However when I tried to re-install the Europe map on the (16GB) SD card, MyDrive wouldn't recognise the card. Fortunately I had another SD card, so I put that into the TomTom, formatted it, and MyDrive recognised it. I downloaded the Europe map and we're now back in business!

    I just hope that this will help anyone else who hits the same problem as I did...

    Best regards

  • DougLapDougLap Posts: 8,224
    Hi @RainKap

    Thank you for posting as this is just how we learn ways to sort out problems.

    Can I suggest that you try formatting yourSD card again to Fat32 and in case it is what you did before a Full Format not a Quick format. If that does not work try the Free Sandisk Format tool which is a free download.

    Trying the above will hopefully restore the card to fully work, if so try it in your GO500 ,or will show there is a problem with the card.

    Now one thing to do now is to leave the small map on the device as should you ever have a problem with the Europe map during an update and the map becomes corrupt or you lose it the Algeria map will ensure you can start he unit normally. You can then resolve the Europe map problem by deleting the corrupt map and or reload the Europe map.

  • YamFazManYamFazMan Posts: 19,625

    You might want to try the... The SD Association SD Memory Card Formatter
    See... SD Memory Card Formatter for Windows....

    See... SD Memory Card Formatter for Mac....

  • RainKapRainKap Posts: 7 [Apprentice Traveler]
    Thanks for the suggestion, @YamFazMan. My main PC runs Linux (Mint); I borrow my wife's (Windows 10) PC to run MyDrive (shame there isn't a Linux version...). The Linux tools for formatting flash memory devices seem to do the job OK; after I had the hiccup with trying to use the 16GB card in my TomTom I reformatted it and used it successfully in my tablet.

  • Lizanne62650Lizanne62650 Posts: 5 [Master Traveler]
    Thank you @RainKap ! I had the exact same problem as the one you posted originally. Tried the "device restoring" thing dozens of times to just get into a permanent loop.I even left it running all night, hoping it may just do the trick, but nothing worked.

    In desparation I searched the forums and your solution of removing the SD card, installing a small map and then adding a new card and downloading my big map worked a treat.

    I thought my old Go500 was destined for the scrap heap, but it lives on, thanks to you.
    So very grateful!

  • RainKapRainKap Posts: 7 [Apprentice Traveler]
    Glad it helped :-)
Sign In or Register to comment.

Who's Online in this Category0