GO 620 connection failure to MyDrive and Traffic

oberon
oberon Registered Users Posts: 23
Outstanding Explorer
edited December 2021 in Devices using Wi-Fi®
My new GO 620 cannot connect to MyDrive and Traffic via Bluetooth / Smartphone (internet). I have done both a soft and factory reset and uninstalled/ reinstalled MyDrive on my smartphone (Samsung Galaxy S 4) but to no avail. Are others having the same problem and is there a fix?

Comments

  • oberon
    oberon Registered Users Posts: 23
    Outstanding Explorer
    Hi Niall,

    From my understanding my problem seems to be different to the one you advised me to look at. My unit can access MyDrive Connect, MyDrive app and traffic via WiFi, but cannot access MyDrive and Traffic via my Smartphone. What is your thoughts about this?
  • Niall
    Niall Posts: 11,130
    Superuser
    @oberon

    In another post
    VikramK wrote:

    Another problem is with the logging into TomTom Services or MyDrive on the devices(mostly WiFi) - Getting the error- Oops We are having trouble accessing TomTom services. Please try again later. This for the moment seems to the related to the point 2 (in the banner link)
    is this what you get?
  • oberon
    oberon Registered Users Posts: 23
    Outstanding Explorer
    I think I've had some luck with resolving the problem of not being able to connect to Mydrive and Traffic via Bluetooth/Smartphone. For the third time I have uninstalled / reinstalled the Mydrive app and by doing this the unit is now working correctly.
  • IreneR
    IreneR Registered Users Posts: 2
    New Seeker
    @oberon

    I’m having the same problem as you. Unstable connection from my iPhone 13.1.2 to Go 620. Any solution? I’m thinking of returning the Go 620 if there is no solution on the horizon. What’s the point if you can’t get traffic?
    BBCode
  • Baz909
    Baz909 Registered Users Posts: 6
    Apprentice Traveler
    I'm having the same problem since the latest big update on my GO6000. Tried reset. Still having GPRS Disconnected. TomTom sevices are temp unavailable. Try again later.
  • jiceman
    jiceman Registered Users Posts: 21
    Master Explorer
    Same issue here. Go 620. Traffic and MyDrive do not work over an iOS hotspot connection, but do work on other WiFi connections. MyDrive app on the phone does not see the Go 620 as connected (either via WiFi or Bluetooth).
  • jiceman
    jiceman Registered Users Posts: 21
    Master Explorer
    Looks like it is a known issue and something that won't get fixed.


    pstfqs92rr7b.jpg
  • Baz909
    Baz909 Registered Users Posts: 6
    Apprentice Traveler
    My unit is actually a GO 6100 and has mysteriously started picking up the GPRS signal again ???? Thank goodness as I was seething after being told via phone and senior engineers that the sim had corrupted and that was that. They sent me a discount of 25% for a new one. Not very wise to human nature are they?
  • Baz909
    Baz909 Registered Users Posts: 6
    Apprentice Traveler
    The thing is I never come across any mention of cleaning the SIM card contacts. Guess what after removal of said sim and a good cleaning my unit is as good as new, how about that. Now fully functional. Senior engineers!