Navcore update TomTom ONE — TomTom Community

Navcore update TomTom ONE

My ONE (S/N PB3178A2026) is currently running navcore 8.017. I need to update it to navcore 9.541 to deal with the GPS weekly rollover issue. I've tried, unsuccessfully, to get a TomTom customer support person to understand that issue and was incorrectly told to install MyDrive, which is not compatible with the ONE. How can I get the ONE to update to 9.541? TomTom HOME does NOT see this as a file that can be installed during the update process. Thanks in advance for any assistance you can offer.

Answers

  • VikramKVikramK Posts: 9,905 Moderator
    Hi @Michael_Shapiro

    Although the device is not supported officially I see that you have an active map on your account.

    Could you also check on this link if there is an update available to fix the GPS effect after the WNRO?

    Regards
    Vikram :)
  • tiljestiljes Posts: 249 [Exalted Navigator]
    @Michael_Shapiro Which GPS chip is your TT One using? SiRF3 or GL/GL1? In the first case you need to update the GPS firmware to GSW3.2.5, in the latter case you need to apply my unofficial workaround from www.rima-lock.com (take the one for Rider K4).
  • Michael_ShapiroMichael_Shapiro Posts: 5 [Apprentice Traveler]
    Hi Tiljes. Thanks for the link. I do not know how to determine which chip my TomTom ONE is using and I do not see a "ttn" file in either my Program Files folder or elsewhere. A bit more guidance would be GREATLY appreciated. Thanks!
  • tiljestiljes Posts: 249 [Exalted Navigator]
    @Michael_Shapiro Sure. Is it a "One", or a "One 3rd"? What are the first to digits/letters of the device ID (not the S/N)? If it's just a "One", pretty sure you'll need the GSW3.2.5 firmware update. What error are you actually experiencing?
  • Michael_ShapiroMichael_Shapiro Posts: 5 [Apprentice Traveler]
    edited December 2019
    Hi Tiljes

    Bottom of unit has the following numbers:

    4EE0.001.00
    N14644 and
    a Serial Number of PBxxxxxx026

    The clock TYPICALLY resets to midnight each time I boot the unit up and when I go to TomTom's site it reports there are no updates available. This would seem to be a GPS weekly rollover issue however I saw a thread you were on that included looking for the file ttgo.bif so I just plugged my unit into my computer and lo and behold it had the almost correct time (it was one hour off due to DST/EST issues). When I scrolled through the unit's options I found a new icon/link for something called TTconv (WNROK4) on menu 3 of 3. Clicking on it simply returned me to the home screen for options. I then went to the clock and set it for the correct time. Restarting the unit (it was still plugged into the computer) revealed the correct time so perhaps I'm headed in the right direction.

    Note that the TomTom version is 8.017 according to the unit's screen. I was hoping to get that up to 9.541 for the GPS weekly rollover issue.

    Just connected to satellites, I'm indoors so the signal is quite weak, and the time remains correct.

    I got the unit connected to TomTom Home and using Windows Explorer I opened the ttgo.bif file with Notepad. Is reports NO GPS Firmware Version! See first several lines of the report below:

    [TomTomGo]
    DeviceName=TomTom ONE
    DeviceVersionHW=ONE (v8)
    DeviceSerialNumber=PB3xxxxxxxx026
    DeviceUniqueID=AKTHE AJH56
    RamDiskVersion=20081015
    BootLoaderVersion=55026
    LinuxVersion=238932
    ApplicationVersionVersionNumber=8017
    ApplicationVersion=9381
    UserLanguage=English US
    UserName=PB3178A02026
    LastConnectionTime=Never
    GPSFirmwareVersion=

    Wondering if I'm on the correct GPS firmware version as the report is empty, and how to move up from TomTom (application) version 8.017 to 9.541. Any help you can offer would be most appreciated.

    Thanks!

    Mike


    Mod edit: Please don't private or personal information on a public forum. Thanks!
  • tiljestiljes Posts: 249 [Exalted Navigator]
    @Michael_Shapiro empty line on GPSFirmwareVersion indicates that your TT isn't using SiRFstar3 GPS chip. Probably GL1. Since you see this extra icon in menu, it seems like you installed my patch correctly. Never tried it on 8.017, but if the time stays corrected after connecting to satellites, it's probably working on that NavCore as well.
    9.541 was never officially released for your TTOne, this is why you don't see any update offers with TT Home. But even if it was available, the 9.541 doesn't cure the time problem with devices with GL/GL1 GPS chip. There is no update available anywhere in the world for the GL1, thus you would have to use my workaround anyways. (would be possible, but nobody with the resources would put the needed work in it for this ~15 year old GPS chip).
  • Michael_ShapiroMichael_Shapiro Posts: 5 [Apprentice Traveler]
    Tiljes

    Thanks for educating this GPS padawan. Since the only reason I really wanted to upgrade to navcore 9.541 was the GPS weekly rollover issue, I'm happy that your little workaround has solved that problem.

    I'm grateful for this community and members like you that offer their assistance.

    Happy GPS'ing.

    Mike
Sign In or Register to comment.

Who's Online in this Category0