Updates stuck

LesCzzzzzzzzzzzzzzzzzzzzzzzz Registered Users Posts: 1
New Traveler
edited January 2019 in MyDrive Connect
Updates are sticking at Waiting for your device. I have tried two different PCs and the same happens. Initially MyDrive Connect said my memory was full but I fitted an SD card and formatted it okay. I have tried leaving it for an hour, unplugging the USB cable and turning off the power to the Tomtom but it continues to report Waiting for your device. I also turned off the firewall to no effect.


  • nadeems tomtom
    nadeems tomtom Registered Users Posts: 33
    Prominent Wayfarer
    hi there a rang tomtom today and they confirmed that there is a issue with updating speed cameras on there side and that engineers are looking to fix the problem very soon i too cannot get past waiting for your device hope that they will be fixed very soon :sunglasses:
  • Jabba46
    Jabba46 Registered Users Posts: 7
    Apprentice Traveler
    Not working. Unable to updates.
  • evem
    evem Registered Users Posts: 6
    Apprentice Traveler
    My device has been stuck on update for almost two years now and all I've got from tomtom support was a "it's a known issue and we are working on a fix". That was 6 months ago...
  • DougLap
    DougLap Posts: 10,116
    Hi @evernew

    Which device?

  • swanner
    swanner Registered Users Posts: 2
    Novice Seeker
    trying to updat tomtom go 60, windows 10 connects to the nav unit, it downloads the nav4 update at 100 percent, then it says waiting for device, then it just shows updating device, still connected, but no progress indicator or anything, been running allday and all night, nothing,d tried uninstalling mydrive and rebooting everything, still will not get past this point.... very frusterated......
  • DougLap
    DougLap Posts: 10,116
    Hi @swanner

    Could you try deleting My Drive Connect from your PC using Revo Uninstaller then Restarting the PC and loading the latest Software from the Tomtom website.

    Did you do a Soft Reset on the GO 60 ie with the unit running hold the ON/OFF button down for about 20 seconds plus until you hear the Drumroll sound then let the button go.

    Le us know in the meantime maybe @VikramK can have a look at the Logs at their end to see if there is something causing a problem and sort that out for you .

  • Rikus
    Rikus Registered Users Posts: 1
    New Traveler
    I had this problem with my sat-nav. It would be stuck on Waiting For Your Device before saying it was disconnected. I'm not sure how, but I found a video detailing how to make sure that your device drivers for it were up to date.
    I followed the instructions, rebooted the laptop and the updates downloaded and installed straight away. This might solve some of your problems. Just thought I'd share!
  • YetiGuy
    YetiGuy Registered Users Posts: 1
    New Seeker
    Have been having trouble with updates on the Go 5100 ever since I purchased it in April 2016. Now have a new Win10 laptop and it doesnt work at all on that.
  • YamFazMan
    YamFazMan UKPosts: 21,322

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu... You will need to edit the Registry before the USB Selective Suspend menu will display (See Note... (4) below)

    Laptop users also see Note (1) (2) & (3)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu

    kt9idp9azgzl.jpgNote...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    Note... (3) Thanks User 333....
    (Quote)... Just had a similar problem with new Dell XPS 13 7390 (running Windows 10) which only comes with USB-C port. Found that I was able to update my TomTom Via 225 (using a supplied USB-C to USB-3 cable/hub) only after changing this setting in Windows 10:
    Settings - Device - USB - Un-tick this box: 'Stop devices when my screen is off to help save battery'
    If you're having problems with connected devices, clear the check-box (End Quote)

    Note... (4) Editing the Registry... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855

  • Josie777
    Josie777 Registered Users Posts: 2
    New Seeker
    You don't need to wipe out and download the whole MyDrive Connect application. All you need to do is get rid of old files. You can do that in the settings:
    1. In TomTom MyDrive Connect application, go to the Settings (top right hand corner).
    2. Select the Downloads tab.
    3. Click on the Empty download button to clear old files.
    4. Try the download again. It should work this time.