Speed cameras and other warnings have stopped working Why? — TomTom Community

Speed cameras and other warnings have stopped working Why?

rogeratendalerogeratendale Posts: 6 [Master Traveler]
I have a Go 520 with wiFi and lifetime maps and speed cameras. Suddenly the speed cameras and other warnings have stopped. I have done a re-set, reinstalled My Drive and checked that speed cameras etc are all switched on in settings. Still nothing.

Answers

  • LochfrassLochfrass Posts: 14,164
    Superusers
    Hello and welcome to the Forum,

    Have you connected the Satnav via Bluetoothtethering or with the MyDrive App to a Smartphone, so that the device can connect to the Internet?
  • rogeratendalerogeratendale Posts: 6 [Master Traveler]
    Hi thanks for answering. I have the Bluetooth on for phone calls AND My drive via my iPhone. It has always worked perfectly for the past year and then suddenly I got no warnings for any speed cameras or anything else. I have checked my status and it says both maps and speed cameras are "active". I am getting fed up with Tom Tom!
  • LochfrassLochfrass Posts: 14,164
    Superusers
    I Think the best is you try to call support.
    They can look at your account. For Phone Numbers you can look here
    https://discussions.tomtom.com/en/discussion/1115662/phone-numbers-to-contact-customer-support-new/p1
  • rogeratendalerogeratendale Posts: 6 [Master Traveler]
    Thanks for that, it’s helpful. I couldn’t find anything on their awful website. I’ll give them a ring tomorrow.
    Thanks again for your help.👍🏼
  • lampardlampard Posts: 5,142 Moderator
    Hi @rogeratendale

    Welcome to the Community! I only see the 'Andorra' speed camera's installed on your device. Can you connect your device to WiFi and go to Main Menu> Settings> Updates & New Items> Tap on 'Speed Camera update'> Select UK in the country list to update.

    Once you do this, give it a test run to see if it works again.

    Regards, lampard
  • rogeratendalerogeratendale Posts: 6 [Master Traveler]
    I tried that but it won’t let me change countries because it says my Tom Tom is up to date and therefore I can’t do anything.
  • rogeratendalerogeratendale Posts: 6 [Master Traveler]
    Your solution will not work: I go to main menu, then Settings, then Updates and New Items and it simply says "Your TomTom Go 520 is up to date!"
    There is no other option and certainly not to change countries. I ONLY have Great Britain and Ireland maps so how can I possibly have speed cameras for Andorra? Andorra is not even listed as a country for which I could get speed cameras on your website.
    I would be very grateful for a PROPER solution to my problem.
    Perhaps I would be better buying a Garmin?
  • bloodyhellbillbloodyhellbill Posts: 1 [New Seeker]
    No speed cameras or traffic after last update! Both active. I see a lot of other people are having the same problem.
    What are TomTom doing about it?
    As it seems to be a common fault, time for a patch and get it sorted, very unhappy customer.
  • rogeratendalerogeratendale Posts: 6 [Master Traveler]
    edited November 2019
    Quite right Mr Bill I posted on the “Resolver” website and got a response from Tom Tom saying they had done a “push” (?) and to do a re-set and download cameras again on updates. Haven’t had Chance to check if it worked yet. I am totally fed up up with TomTom I’ll buy a Garmin next time.
    Glad it’s not just me though!!!
Sign In or Register to comment.

Who's Online in this Category0