Unknown navcore version- Built in navigation device — TomTom Community

Unknown navcore version- Built in navigation device

bryandangfangbryandangfang Posts: 2 [Apprentice Seeker]
edited August 2019 in Built in car navigation
i want to update my sd card with the latest version of maps.
I get the following message:
This smart media system memory has been corrupted
Please insert the smart media system memory card into the navigation device in your car

when the card inserted in the car it works fine.


  • dhndhn Posts: 33,350
    Maybe support can assist:

    :flag_sg: Singapore
    1800 622 7266
    Monday - Friday: 09:00 - 17:30
  • YamFazManYamFazMan Posts: 19,670

    Found this...
    Smart Media-Systems
    Smart Media-System shows 'Unknown navcore version' when connected to MyDrive Connect
    That error appears when software 11.344.3064886 is installed
    It's the Navcore version which has not been released yet so this version it will be unrecognised
    There is no need to troubleshoot that we are doing our best to update our system asap
    There is no workaround available at the moment

  • bryandangfangbryandangfang Posts: 2 [Apprentice Seeker]
    Today the clock on the navigation display is gone only two dash and one double dot how to solve this issue
  • DougLapDougLap Posts: 8,261
    Hi @bryandangfang

    Have you checked whether there is an Update available.

  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    I have navcore version 11.344.3198541-8509 with same unknown navcore error on smart media system
  • lampardlampard Posts: 5,394 Moderator
    Hi @sunnysmart

    Welcome to the Community! I've made some changes in background to fix this, please follow the steps below to apply these changes:
    • Please connect the device to MyDrive Connect running...
    • Click on the Cog Wheel Icon Screen top right
    • Click on the Downloads Tab
    • Empty download folder
    • Save settings and the device will reboot after few moments.
    Let us know how it goes!

    Cheers, lampard
  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    yeah don't seem to have that bit as for the smart built in you use "smart media connect"
    as soon as I log in I get the attached
  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    ah found the bit you refer to under the union jack icon cleared the folder down, but no change.
    I have a case open with tomtom - who say they are working on it.
  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    still waiting they have closed my case as no solution yet - great - very helpful
  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    does anyone have leverage with tomtom as they have not fixed this, I cant believe that so few peeps are complaining about this
  • SmartCicioSmartCicio Posts: 8 [Master Explorer]
    I've the same issue, from may 2019, Ive asked to the support, but until now, they donthave any solution, it's incredible!
  • MissPiggy71MissPiggy71 Posts: 1 [Novice Seeker]
    OK, so my Smart Car in-car media is saying disconnected and no Live Traffic etc. So, I've paid for update service on Tom Tom account (expired Sep 2019 apparently). I now can't find that product against my account details, nor find a way to download to my SD card for the car. I've tried installing TomTomMyDrive to do this and it says Navcore version not recognised, even though just downloaded from TomTom site. So how do I get my £54 piece of software onto my SD card to update my car system??
  • Troubadix12Troubadix12 Posts: 1,994 [Revered Voyager]
    Hi MissPiggy71,

    you have to use SmartMediaConnect for a Smart, not MyDriveConnect.

    What Services do you purchased? Live-Services? SpeedCamera-updates? Map-Updates? All Together? LiveServices (Traffic) are not installed via SmartMediaConnect. That are Online-Services via SIM-Card in your InDash.


  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    seven months now with out updates as they keep giving me the runaround. " we're working on it". couldn't use the backup solution as it was not suitable as I didn't have my own backup so didn't want to risk corrupting the sd.
  • IamSandieIamSandie Posts: 1 [Apprentice Seeker]
    Im having the same run around from TomTom since March2020 & seems like the problem - UNKNOWN NAVCORE VERSION has been round for a good while. How long do they need to ‘work on it!’ So disappointing & totally unacceptable. If anyone has a solution to this please let me know. Unable to use Sat Nav at all as it doesn’t have UK maps on so it’s useless 😠I’m having to use WAZE app
  • sunnysmartsunnysmart Posts: 12 [Legendary Explorer]
    dont know what is going on with tomtom, still no resolution of issue with navcore version ending 8059 and then yesterday I find this browsing the smart eq website


    I downloaded and applied to my broken satnav via usb stick in the car, the sd card gets updated by this and SURPRISE I get an upgrade to navcore version ending 8060 and SMART MEDIA CONNECT starts working again.

    but this time I am smarter, backed up the sd card using rlink explorer via this link


    AAARRRGGHHH, how long has this been on there , why didnt tomtom tell me about it...................
Sign In or Register to comment.

Who's Online in this Category0