Bluetooth connectivity issues for Wi-Fi devices and iOS 13 - Page 4 — TomTom Community

Bluetooth connectivity issues for Wi-Fi devices and iOS 13

1246720

Comments

  • thabisothabiso Posts: 2 [New Seeker]
    My device doesn't get to start after I have done the latest update, it switches on and try to open and goes blank.
  • DougLapDougLap Posts: 6,417
    Superuser
    Hi @thabiso

    Try continuing to hold the On/Off button down and see if you hear the drumroll sound at which point let the button go.

    Doug
  • thabisothabiso Posts: 2 [New Seeker]
    I have done it couple time already and still not winning. I will continue doing it.
    DougLap wrote: »
    Hi @thabiso

    Try continuing to hold the On/Off button down and see if you hear the drumroll sound at which point let the button go.

    Doug

  • CEEatonCEEaton Posts: 7 [Apprentice Traveler]
    Joe Q wrote: »
    I have followed all the steps indicated by dmulv and VikramK five times in the last two days. Thank you both for the suggestions above. I still cannot get a traffic connection. Devices are GO 620 and iPhone iOS 13.1.2. As others have indicated, everything works well...in my house on WiFi. I appreciate the ongoing work of TomTom’s Tech staff working on this problem. I hope you all come up with a solution soon.

    Following this as trouble shooting hadn’t helped me either with Go 620 & 13.1.2
  • Graham1958Graham1958 Posts: 11 [Legendary Explorer]
    I have tried everything now and still only have hands free on my Go Professional 620. The Tom Tom is showing connected on my iPhone 13.1.3 via Bluetooth but the sat nav is showing unable to connect to traffic or mydrive. I am beginning to think the problem is with the mydrive on the satnav.
    I am fed up now of the only answer you get from Tom Tom is to keep deleting everything and to reinstall . I have lost count of the times I have tried this when will Tom Tom realise IT DOES NOT WORK..

  • Nigel ANigel A Posts: 100 [Renowned Trailblazer]
    Had another go at my rider520 hands free connects for 30 second or so and lose it all. Have noticed that my iphone connects with my car and my senna headset, my headset connects with the rider520 and my phone. my phone connects via hot spot to my 520 for traffic only (Or to my car) the only common thing is that tomtom require the phone app to connect Bluetooth, for the hands free. Is this a IOS 13 problem or a problem with the mydrive app ? this has been suggested before.
  • AndersNordhAndersNordh Posts: 275 [Supreme Navigator]
    edited October 2019
    https://www2.andersnordh.se/filestoshare/IMG_0212.mp4

    Worlds most boring video but ... Ansluten = Connected, Inte ansluten = Not connected and Inget Internet = No Internet.

    Latest software, firmware ... same on two different IPhone models ...

    Now, to be honest it works pretty well after the first pairing but after a re-connect this is what's happening.

    /Anders
  • johnsondvrjohnsondvr Posts: 28 [Prominent Wayfarer]
    https://www2.andersnordh.se/filestoshare/IMG_0212.mp4

    Worlds most boring video but ... Ansluten = Connected, Inte ansluten = Not connected and Inget Internet = No Internet.

    Latest software, firmware ... same on two different IPhone models ...

    Now, to be honest it works pretty well after the first pairing but after a re-connect this is what's happening.

    /Anders

    Exactly what is happening to me. Initial connection was fine but then issues on reconnect.
  • M1chaelM1chael Posts: 2 [Apprentice Traveler]
    Tomtom support does barely react to support questions on this topic let alone solve the issue. I have updatet my Tomtom GO 520 and Rider 550 to the latest firmware, done full resets, removed Mydrive App and BT connections from my iPhone Xs (with ios 13.1.3) and still no Tomtom traffic or MyDrive. The Tomtom units do make a BT connection, but the devices keep stating "No Internet". In my BT settings 2 Tomtom connections appear per device. If i look at the phone connection on my devices, it is stuck on "Connecting" for Traffic and other services and Smartphone messages.
    I am thinking about returning the devices and demanding a refund.
  • Graham1958Graham1958 Posts: 11 [Legendary Explorer]
    This problem has been going on for weeks I have a Go Professional 620 and the only thing that connects is the hands free. I have also tried everything they have suggested, I’ve lost count on how many times they have told me to re-set to factory settings and deleted mydrive from my IPhone which is using EE net work.
    My phone shows that the Tom Tom is connected through Bluetooth but the sat nav keeps showing unable to connect. I have emailed Tom Tom and set them photos showing the problem but they keep coming back with the same answer re-set / delete.
    I now keep getting emails from them advertising how wonderful their sat navs are, and services namely Traffic.
    I have also emailed them that if they don’t sort this out I want my money back as this sat nav is not fit for purpose because all I have is the hands free which is not why I paid the extra money for.
  • M1chaelM1chael Posts: 2 [Apprentice Traveler]
    I say we demand a refund. This way the device is no more useful than any cheap satnav device.
  • CEEatonCEEaton Posts: 7 [Apprentice Traveler]
    M1chael wrote: »
    I say we demand a refund. This way the device is no more useful than any cheap satnav device.

    I've just tweeted them, suggest we all do the same. It's amazing how fast things are responded to and fixed once a Twitter storm starts!

    So frustrating, I paid more for this satnav, needing the traffic for work. If I'd known it was never going to work properly, I'd have bought a cheaper model and worked it alongside google maps :s

  • PaoloDiellePaoloDielle Posts: 1 [New Seeker]
    Bus driver for over 30 years, I had the misfortune of buying a tom tom 6250, nothing to say about image, update etc ... but the connectivity seems ridiculous but IT CANNOT BE CONNECTED TO ANY KIND OF BLUETOOHT HEADSET! ! But would it be for "Professional" use ?? Who is the amateur who never thought about using noisy media by nature ?? The idiot who thought it and 'never been on a bus with 60 people talking ?? and the security, guaranteed by the power to have information in the headset, where is it going to end ?? tom tom "professional" .., great disappointment, not to buy ..
  • juresjures Posts: 85 [Sovereign Trailblazer]
    Another one here in Sloveia, just had a trip 1500km with no traffic info, beacuse BT connectivity with IOS 13.1.2 DOES NOT WORK!
  • ChrispybChrispyb Posts: 6 [Master Explorer]
    edited October 2019
    YEEES! Bluetooth is working again.

    Having followed this thread for the last few weeks and having the same problem as everyone else with Bluetooth / iOS connectivity, I’m relieved to report that I finally have it working.

    I upgraded my iPhone Xs to the brand new iOS release, 13.2, this morning, reset my Go 520 Wi-Fi to factory settings and linked up. Initially the traffic and messaging wouldn’t link but that was resolved by switching the Go 520 off and on again (just on and off, not a reset) and then everything linked in seconds. I’ve had a stable connection for several hours. I’ve just disconnected and re-connected and it’s still working fine.

    Phew! It looks as if it was ultimately an Apple issue but I’m still disgusted that TomTom stayed so quiet about this. I wonder how many hours users have wasted in total because of the arrogant attitude of the TomTom team in refusing to update the information after their initial attempt at a software fix failed to resolve the issue.
  • ClausBPClausBP Posts: 6 [Master Traveler]
    edited October 2019
    GOOD NEWS - UPDATE: I thought - connection lost after 2 hours!!!

    I checked my iPhone 6S for updates and updated to IOS 13.2 (it did not happen automatically - so go and search for updates.)

    I reset my TomTom Go Basic + deleted My Drive on the iPhone + "forgot" both TomTom connections in Bluetooth settings.

    Thereafter I connected bluetooth again and now it seems to work - 1 hour at least :-) UPDATE: connection lost after 2 hours!!!

    Dear TOMTOM - your information regarding this issue has been terrible.

    A serious issue like this impacting so many customers should be on the front page of your support site with daily updates - even though it seems to be caused by a partner (Apple)
  • ChrispybChrispyb Posts: 6 [Master Explorer]
    I spoke too soon, it’s not working again this morning 😡
  • johnsondvrjohnsondvr Posts: 28 [Prominent Wayfarer]
    Placed a second query with support and this is the response:

    “ I have now discussed this issue with our 2nd line technical team and we do have same issue reported by some other customers as well. Based on this we have created a ticket to be investigated on this and forwarded it to the developers. Our developers are actively looking into this issue impacting some owners of some TomTom devices. I regret that at this time they have not determined the underlying cause and cannot therefore give me any reference point on when they will have the issue fixed. We continue to investigate the issue and look forward to pushing an update via MyDrive / Updates and New Items on device to resolve this issue as soon as possible. In the interim please accept my sincere apologies for any and all frustrations incurred.
    With kind regards, “

    Also noticed the banner for this issue has been removed from the landing - I suppose TomTom did not want to flag that they have a serious problem!. Still no resolution from this update a week ago.
  • Graham1958Graham1958 Posts: 11 [Legendary Explorer]
    Johnsondvr I was sent the same thing over 3 weeks ago and still Tom Tom don’t have the decency to let their customers know what is going on.
    The only thing working on my satnav is the hands free, oh and today they have sent me an email advertising how wonderful their services are on their devices 😡
  • derosask1derosask1 Posts: 3 [Apprentice Traveler]
    Still nothing!!!
    Tomtom are bloody useless. Wish I'd bought the garmin...
Sign In or Register to comment.

Who's Online in this Category0