Server Busy all the time- MyDrive Connect

wrightshouse Registered Users Posts: 1
New Seeker
edited October 2019 in MyDrive Connect
My Drive Connect no longer works on the site with my Via 1430/1432. says it's downloading for about 5 minutes then it says "our site is busy, click retry". Makes no difference. Been "busy" for 3 days now.


  • LAURE123
    LAURE123 Posts: 1,632
    Hi @wrightshouse

    Can you try to do a Soft Reset of your device then a clean installation of My Drive Connect (MDC) with a fresh copy, we just got a new version. Sometimes it works.

    First the Soft Reset:
    With your device Not connected to the PC ==> Press and hold the On/Off button until you hear the drum sounds, release the button. This can take 30 seconds or more. The device's Restart will take longer with frozen screens, it's normal.

    For MyDrive Connect with your device Not connected to the PC:
    1/ Uninstall MDC, accept the removal of downloads in the popup window.
    2/ "Restart" your PC (Not Shut down or Sleep)
    3/ Download and install the last version MDC, take it here:
    - On this page, at the bottom, the green button "Download for ...":
    - In the popup window, keep ticked at least "Download updates on my computer (recommended)", the other choices are optional.
    4/ "Log in" with your email and password in MDC.
    5/ Connect your device.

  • discodave1
    discodave1 Registered Users Posts: 2
    Apprentice Traveler
    edited October 2019
    hi i have a 820 that will not update my drive says server busy have tried but still wont update.
  • shonluke61
    shonluke61 Registered Users Posts: 2
    New Seeker
    ditto..i am trying to update my via 280. I keep getting 'the server is busy, try again later' or Failed to download content for your TomTom Via 280 with ID xxxxxxxxxxxxxxx
    Please consult your network settings.
    The URL is as follows:
  • lampard
    lampard Retired TomTom Employee Posts: 6,075 Retired Community Moderators and Admins
    Hi @discodave1

    Welcome to the Community! Can you please try the troubleshooting steps mentioned by @LAURE123 in the link here? Let us know how it goes.

    Regards, lampard
  • shonluke61
    shonluke61 Registered Users Posts: 2
    New Seeker
    Hi....tx for the advice. It worked. 'soft setting' my device is the only thing extra that I hadn't already tried......and that was the difference. cheers.....any idea why my VIA 280 is being called a VIA 1535 on my account??
  • LAURE123
    LAURE123 Posts: 1,632
    Hi all


    The same devices don't have the same name in different parts of the world, EU/US/AUS.

    You can check in MyDrive Connect the selected country and change it if needed:
    ==> open MDC and click on the "gearwheel" at the top right to open the "Settings" window or right click on the TomTom icon in the taskbar and then "Settings".
    ==> in the "General" tab choose your country, Australia, then click on the "save settings" button.

  • A_J_F
    A_J_F Registered Users Posts: 1
    New Seeker
    I have just this evening run in to this after My Drive Connect software updated.

    I got it working again in the end after completely uninstalling My Drive Connect and all updates for My Drive Connect from my computer. Then downloading and reinstalling the latest available version of My Drive Connect.