Tom Tom One 3rd Edition not finding satellite. — TomTom Community

Tom Tom One 3rd Edition not finding satellite.

Hello, I have a Tom Tom one 3rd edition. I noticed this past week when trying to enter a destination that satellites are no longer consistently found on the device. Is this common for the device?

Thank You,

Best Answer


  • VikramKVikramK Posts: 12,546 Moderator
    Hi @panorian

    Welcome to the community!

    I don't find the device linked to your account on the forum. Did you check if it's affected by the WNRO?

  • panorainpanorain Posts: 6 [Master Explorer]
    edited September 2019
    I have noticed when leaving the TOM TOM One 3rd edition plugged into my computer after some time 'undetermined as of yet how long exactley' the route is in fact displayed and the device will receive a signal. Why is it taking so long now though?

    Thank you for your response. When I enter the serial number of my device nothing is returned on the above page you listed: ---->

    When I do go to this page: ----> <---- Toward the bottom of the page the following message is displayed. Important:​ Your device is no longer supported through phone , and it's not possible to buy new maps and services for your device. You can still get help through our user forum and FAQs. More information.

  • tiljestiljes Posts: 249 [Exalted Navigator]
    @panorain When you connect it to your PC, there should be a file "ttgo.bif". If you open this with a text editor (e.g. "Notepad"), what does it say for the line "GPSFirmwareVersion"?
  • panorainpanorain Posts: 6 [Master Explorer]
    Thank You very much for your message. Currently all the computers I have connected are running A version of Linux. I do have a desktop that has Windows XP installed. I will need to connect it. I will get that on my list of things to do.

    Thank You. :]
  • tiljestiljes Posts: 249 [Exalted Navigator]
    @panorain You can also connect it to a Linux-PC. You could even connect it to an Android device with a USB-OTG adapter.
  • panorainpanorain Posts: 6 [Master Explorer]
    @tiljes I have the TOM TOM One connected to my Linux-PC right now with what I think is named a USB-OTG adapter but the adapter I am using has a male usb end plugged into a usb slot on the pc. The TOM TOM One is recognized.

    I opened the "ttgo.bif" file and the "GPSFirmwareVersion" is as follows:

    It's very nice to have tried again and in fact see now that in terminal 'lsusb' command does in fact show the TOM TOM One as: ----> TOMTOM B.V. GO 520 T/GO 630/ONE XL (v9)

    Thank you much for your help and I apologize for my slow reply.
  • panorainpanorain Posts: 6 [Master Explorer]
    Thank You tiljes. The unofficial way you suggested does in fact seem to work at least for now. The GPS does pickup a signal fairly quickly now.
  • digi2000digi2000 Posts: 5 [Master Explorer]
    Thank you so much, tiljes for this geat GPS-Firmware Update to GSW3.2.5 (for SIRFIII GPS-Chip). Now, all WNRO problems with my device TT ONE 3rd Edition are gone ;-))
  • digi2000digi2000 Posts: 5 [Master Explorer]
    edited October 2019
    sorry - can be deleted
  • Smurf_Tom_2005Smurf_Tom_2005 Posts: 48 [Sovereign Trailblazer]
    There is even the unofficial firmware upgrade GSW 3.6.0, which is really awesome.
    you can find it by typing in Google: Firmware upgrade gsw 3.6.0
    that has my Tomtom One 3rd. with Gps chip Sirf3 (serial: Y3 ...) straightened.
  • Smurf_Tom_2005Smurf_Tom_2005 Posts: 48 [Sovereign Trailblazer]
    you can find it by typing in Google: Firmware upgrade Sirf 3 gsw 3.6.0
  • panorainpanorain Posts: 6 [Master Explorer]
    @Smurf_Tom_2005 is it correct that the TOM TOM One 3rd has a 'SiRFStarIII chip'? I read through an article about the unofficial firmware upgrade to either GSW 3.2.5 or GSW 3.6.0. The article says that generally version 3.6.0 generally finds 1-2 more satellites than version 3.2.5 but cold starts generally take longer. Have you by chance tested the 2 different versions yourself?
  • Smurf_Tom_2005Smurf_Tom_2005 Posts: 48 [Sovereign Trailblazer]
    Yes, there really is a TT ONE 3Rd. with the Sirf3 GPS chip. starting with the serial number: Y3 and has 512MB of memory.
    I've tried both versions myself and I can only confirm the article about the unofficial firmware upgrade to GSW 3.2.5 or GSW 3.6.0. The upgrade also works on many other EOL sat navs with the Sirf3 GPS chip. It is a pity that Tomtom did not do it himself, for which some users from the German forum were able to. This point clearly goes to the Germans!
  • arfurdent42arfurdent42 Posts: 3 [Apprentice Traveler]
    Thanks for the info about firmware upgrade. Found a UK site with the firmware on it. Works a treat.
Sign In or Register to comment.

Who's Online in this Category0