New software version v19.104 available for download — TomTom Community

New software version v19.104 available for download

VikramKVikramK Posts: 8,369 TomTom Moderator
Hello Everybody,

We released a new software version 19.104 for GO WIFI, PREMIUM, GO PREMIUM X, GO Professional / Trucker and GO Camper/RIDER 500/550

Whats new?

Various bug fixes and improvements have been implemented in this software release.

Edit: Adding the RIDER 500 series to the list.

Thanks,
Vikram :)

Comments

  • Don2641Don2641 Posts: 19 [Outstanding Wayfarer]
    I download the new version but i dont see nothing new.
  • doctormstein1doctormstein1 Posts: 130 [Renowned Trailblazer]
    same here. Can anyone tell me what is new?
  • NiallNiall Posts: 10,599 Superuser
    VikramK wrote: »
    Whats new?

    Various bug fixes and improvements have been implemented in this software release.

    This is NOT acceptable, clarity is needed to restore the bottom line confidence

  • gildersleevegildersleeve Posts: 8 [Apprentice Seeker]
    The last update caused my battery to drain when device is powered off replaced 3 batteries in as many months, been running last few weeks with no battery at all and device has been fine, todays update stopped the device from starting without battery, feels like planned obsolescence
  • VikramKVikramK Posts: 8,369 TomTom Moderator
    edited September 20
    Hello all

    No new features have been included in this release. This update covers a critical fix which makes the device more conversant and stable in terms of maintaining Bluetooth® connectivity with compatible smartphones.

    Read More

    Regards
    Vikram
  • Covkid62Covkid62 Posts: 543 [Revered Navigator]
    Think we have got to accept that Tomtom are not going to update these devices with new features....haven't had anything new to shout about for at least a year....I'm starting to think these devices will be phased out soon which is the reason they have given up....no updates to make poi more acceptable....nothing to sort out aggressive routing
  • PatjepeeerPatjepeeer Posts: 68 [Sovereign Trailblazer]
    @VikramK , is the missing petrol and rest stations issue fixed in this release?
  • VikramKVikramK Posts: 8,369 TomTom Moderator
    Hi @Patjepeeer

    That fix I think will be covered in one of the upcoming releases.

    Sorry, this was just an urgent hotfix release.

    Regards
    Vikram
  • PatjepeeerPatjepeeer Posts: 68 [Sovereign Trailblazer]
    Oke, thanks for replying anyway. Hope that issue will be fixed soon.
  • SerhanSerhan Posts: 4 [Master Traveler]
    Hi,

    I'm using Tomtom Rider 550, iPhone X (ios 13), and Sena20S
    In the user manuel it says I can get directions via Siri directly to Tomtom. Is this correct?
    How can I do this?

    I tried to tap the little phone icon on my Rider 550 screen. This activates Siri and from my Sena 20S I can say my command. But nothing happens. But Siri works. I can play music, call someone, etc.

    When I'm on the road and had some planned route on my Rider 550, and to get some directions to the gas station without using the Rider 550 or phone, just by taping the phone icon and talking, how can i do this?
  • DamageMeDamageMe Posts: 42 [Renowned Wayfarer]
    I was thinking that in this release they will fix bug for rest areas :(
  • HighFlyer64HighFlyer64 Posts: 1 [New Traveler]
    I strongly recommend NOT to install this update if it is 19.104.0017.411. This broke my TomTom GO 620 , which will not longer show an overlay of the route being navigated. I have emailed the support team separately on this issue. Looks like the QA of this update was non-existent.
  • f691gff691gf Posts: 2 [Apprentice Traveler]
    edited September 23
    I just installed the new update 19.104.0017.411 and it removed the route overlay blue color!
    Can you fix it ASAP please!
    i noticed another user complaining too
    https://discussions.tomtom.com/en/discussion/comment/1671768#Comment_1671768
  • miketorcymiketorcy Posts: 3,200 Superusers
    No trouble for me. But the purple blob is still alive!
  • DougLapDougLap Posts: 3,455 Superuser
    Hi @f691gf

    Have you tried the reset suggestions in the Post before yours.

    Doug
  • f691gff691gf Posts: 2 [Apprentice Traveler]
    After doing a hard reset it was fixed, but i dont have to tell u that this was my last choice
  • AndersBAndersB Posts: 2 [Apprentice Traveler]
    I lose Bluetooth on my 520 Go when turning of hands free telco. I don’t want to talk through the
    Navigator. When I turn this on it reconnects.
    Strange...:( it’s also very unstable after latest IPhone update. This takes a lot of energy. I only want to use. Not program al day.
This discussion has been closed.

Who's Online12

Hexenrider
Hexenrider
Lost_Soul
Lost_Soul
MikeReis
MikeReis
+9 Guests