Why your servers are busy? — TomTom Community

Why your servers are busy?

jonnyenglishpantsjonnyenglishpants Posts: 1 [New Traveler]
edited September 9 in Built in car navigation
i paid for a subscription and your severs are busy for the last two days maybe longer, there is noway of contacting you by phone, hopeless firm, still there is always garmin.


  • DougLapDougLap Posts: 3,152 Superuser
    Hi @jonnyenglishpants

    The Contact details are on the website.

    Hereare the UK details

    United Kingdom 02079 490 134

    Monday - Friday: 9:00 a.m. to 5:30 p.m.

  • WeldrithWeldrith Posts: 4 [Master Traveler]
    Fixed it. I had to uninstall MyDrive Connect software and re-download and reinstall. Now it's updating. Shouldn't there be a message stating that needs to be done before the update works?
  • Olly50Olly50 Posts: 1 [New Seeker]
    Similar problem updating Tomtom Start 25, re-install fixed it
  • BJR1BJR1 Posts: 1 [New Traveler]
    edited May 28
    We're May 28th, 2019, this issue is specific to Windows 10 and has been ongoing for a number of months. The issue remains unresolved and users are unable to update devices for which they have either purchased lifetime map support or for which they have laid out big bucks to purchase maps.

    Come on TomTom! Fix this issue or roll it back.

    P.S. Did all of the above this AM and still had connectivity issues with the app. Opened up a Window 2012R2 server VM, installed the MyDrive Connect app and updated my device in 2 minutes. This is a Windows 10 specific issue and should have been corrected by now.
  • Peterlocke1942Peterlocke1942 Posts: 1 [New Traveler]
    Tried updating my maps again, and again but the servers were busy 'Try Again' they say so I did, and again. Then I read a post concerning this problem and the post said go to Programs and Features and completely remove/uninstall the Tom Tom My Drive program, then go to the Tom Tom web site and re-install. Bingo!! its their program not your computer or your device. Thanks to the postee for possibly solving this problem on Windows 10.
Sign In or Register to comment.

Who's Online38

+37 Guests