Software won't run at all.

kharrisma Registered Users Posts: 2
New Seeker
edited July 2019 in Devices using TomTom HOME
Picked up a GO 740 (yeah, I know it's old), and installed the Windows software from the CD that came with it. Process is almost complete, then a pop-up window barges in demanding to update to a newer version, and won't let me do anything other than click on the "OK" for that pop-up. It does it's thing, seemingly successfully, but then the software will not run. All I get is Windows' cutesy "wait" little whirling blue ring which 'blips' a little red icon too quickly to see what it is, and just keeps doing this until I restart the computer. I've uninstalled and re-installed it several times now, and it's consistent... does it every time. So what gives here? How am I supposed to get the TomTomHome software installed?

Forget it... Tried installing the download from the site, the most recent version.... same thing. Plus, I found out support for this thing has ended. Ain't worth the trouble. NOT impressed with Tomtom.


  • DougLap
    DougLap Posts: 10,121
    Hi @kharrisma

    The GO740 is a 10 year old model and is now considered as obsolete by Tomtom. so the he device is no longer supported through phone , and it's not possible to buy new maps and services for your device.

    It however uses the Tomtom Home Software which you can download the current version of from the Tomtom website.

  • kharrisma
    kharrisma Registered Users Posts: 2
    New Seeker
    "Tried installing the download from the site, the most recent version.... same thing."

    But thanks for trying.
  • YamFazMan
    YamFazMan UKPosts: 21,356

    Maybe worth a try....
    Modify Tomtom Home to use older version of tomtom Home... (Mabe usefull for End of Life TomtomDevices with No further map or other updates)

    (1)… Uninstall TomTom Home
    (2)… Download last "good" version from

    (3)… Install it without running....
    ie, un-check the 'Run Home' tick box when installation completes

    (4)... Using Windows Explorer, navigate to
    C:\Program Files\TomTom HOME 2\xul (32 bit Windows)
    C:\Program Files (x86)\TomTom HOME 2\xul (64 bit Windows)
    and find application.ini file
    (5)… Edit application.ini file (you might need admin privileges) and modify "Version=" to "Version="
    (6)… Run TomTom Home. It will believe to be running latest version and therefore not pull the update