My GO Premium X reboot freqently

Using the menu and give a new input before the commando is fully through result in the system halt and the unit reboot. Have you the same experience with the device?

Answers

  • VikramKVikramK Posts: 7,767 TomTom Moderator
    Hi @Nockert

    Welcome to the community!

    Could you do a soft reset(Press and hold the on/off button till you hear the drum sounds) and try again.

    Regards
    Vikram :)
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • NockertNockert Posts: 11 [Master Explorer]
    Yes but that don't fix it. The device works fine during normal navigation but if I manupulate the settings and give a new input when I have change a setting but the device have not finalized the setting change it freeze and after a short moment it restart.
  • ElcuoloElcuolo Posts: 1 [New Seeker]
    Have exactly the same problem with a brand new device. Did anyone get to the bottom of this at all?


    Not exactly the "Premium" service I was expecting....
  • NockertNockert Posts: 11 [Master Explorer]
    Well the problem has gone away, but I don’t know if I did something or it was due to some update from TomTom that fix it, hop you will experience the same.

    /olle
  • G MG M Posts: 7 [Master Explorer]
    I have a similar problem on my brand new (yesterday!) Premium X. If I'm lucky the home screen partially shows, but goes off again very quickly,
    I'm quite old and not that tech savvy to start with
  • DougLapDougLap Posts: 2,805 Superuser
    edited July 19
    Hi @G M

    If it I still doing it after charging it using the rear socket then I suspect that there is something wrong with the unit.

    Doug
Sign In or Register to comment.

Who's Online7

pshen_2000
pshen_2000
+6 Guests