updating issues

jonnymac101 Registered Users Posts: 1
New Seeker

been trying to update my rider 550. tried it on both wifi and through my laptop.

it gets to about 16% then restarts, it then it goes up to 99% then jumps back to 13% and just keeps doing that cycle over and over again. I've reset the system and also done hard restart. its been updating for 36 hours and it just continues to do the same cycle. Any help appreciated.


  • YamFazMan
    YamFazMan UKPosts: 21,343

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work
    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu
    You will need to edit the Registry for the USB Selective Suspend menu to show

    Laptop users also see Note (1) & (2)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu
    Note...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    See... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855

  • ninjaef
    ninjaef Registered Users Posts: 10
    Master Traveler
    edited July 2019
    ?? He's tried it over WiFi so what has USB go to do with that? Sounds to me like he's tried over WiFi to his router and out to TomTom servers. No USB.

    OP - You mention a hard RESTART. Do you mean RESET? If not , have you tried a SOFT reset, and if still not working, a HARD reset?
    Otherwise, something wrong with the device - send it back.