GO 50 device can not connect with iPhone — TomTom Community

GO 50 device can not connect with iPhone

Try to connect "TomTom Go 50" with iPhone 7 and iPhone X running the latest iOS 11 but failed.

The bluetooth pairing is successful. On the device's network setting, it showed the following sign: iPhone(paired). Then a drop down notification: "Phone connected".

However, a wheel keeps spinning before the "iPhone(paired)" sign and below that it indicates that the devices is still "connecting".

Unfortunately, after 15 seconds a drop down notification says: "Unable to connect to TomTom MyDrive". Then a warning page shows up telling me to check if MyDrive app is installed.

I already tried reinstalled the app, reset network setting and have everything up to date. Anyone have any suggestions?

Comments

  • OldChiefOldChief Posts: 1 [Apprentice Traveler]
    Having the same problem with my iPhone 8 and Go 600. Reinstalled software on the iPhone and rebooted but got the same results.
  • ammojrmammojrm Posts: 3 [Apprentice Traveler]
    I'm having the same problem with my Iphone 6 Plus and Go 600. I reinstalled app on iphone and it still don't work. I also updated My Drive Connect on the computer and updated maps but still have the same problem. My phone use to work until the update prior to this recent one.
  • JLP1960JLP1960 Posts: 1 [Apprentice Traveler]
    I'm having the same exact problem as h0ward. I just bought the iPhone X and I cannot connect to my GO 60. I updated the GO 60 and deleted the TomTom app and reinstalled, but the devices still will not connect. They pair, look like they're connecting, but then, "Unable to connect to TomTom MyDrive".

    Does anyone have a solution before I smash my TomTom with a sledge hammer?
  • dhndhn Posts: 33,152 Superusers
    Try support:

    :flag_us: United States
    877-757-7137
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
  • ammojrmammojrm Posts: 3 [Apprentice Traveler]
    JLP1960 wrote:
    I'm having the same exact problem as h0ward. I just bought the iPhone X and I cannot connect to my GO 60. I updated the GO 60 and deleted the TomTom app and reinstalled, but the devices still will not connect. They pair, look like they're connecting, but then, "Unable to connect to TomTom MyDrive".

    Does anyone have a solution before I smash my TomTom with a sledge hammer?
  • ammojrmammojrm Posts: 3 [Apprentice Traveler]
    I had to put my phone and Gps on the kitchen counter side by side. I updated MyDrive and signed out of it several times. I spent about 30 mins playing with it and was about to give up because the Gps battery was low. Not sure what I did but the Gps asked for my email and password to let me sign into my account. Once it connected it started communicating with my phone. I just made a trip and it worked.
  • dbdriscolldbdriscoll Posts: 2 [Apprentice Traveler]
    I’m having the same issue w my Go 60
  • rallen1969rallen1969 Posts: 1 [Apprentice Seeker]
    I can comment that the scenario PDurst noted above ended up providing the guidance to solve the problem with my Go 500 and MyDrive APP on IOS. I have no idea why it suddenly stopped connecting, I had neither recently updated the IOS app nor the GO 500 software.

    Even though I would go through the setup on the GO 500, and it would pair correctly, and the IOS device would even launch the MyDrive APP, it would still spin trying to connect before coming up with the error message on the GO.

    Finding the place to click for Bluetooth is not at all clear in the app - I sorted of stumbled across it accidentally while trying to find what Pdurst mentioned. After tapping on the screen where it notes about not having a Bluetooth icon, I received the question about if I purchased in US, CA, MX, Brazil - and bam - suddenly it just started working on the Go 500.
  • TomMaszTomMasz Posts: 4 [Apprentice Seeker]
    I've been searching for an answer on this for months! Thanks to PDurst for solving what seemed like an impossible problem!
  • autotranautotran Posts: 1 [New Seeker]
    "I've been searching for an answer on this for months! Thanks to PDurst for solving what seemed like an impossible problem!"
    I got lucky, I was looking for less than a hour but if I had tried before Pdurst's April 10th post I wouldn't have found the answer either.
  • berryhillncberryhillnc Posts: 1 [Apprentice Seeker]
    Same issue with my Go 600. Tried all recommendations from TomTom with no resolution. I do get a popup on some pairing attempts from iphone 6S iOS 12.4.1 that TomTon GO600 is not supported.
Sign In or Register to comment.

Who's Online9

jbthor2001
jbthor2001
+8 Guests